Narcissus ?: parsing problem

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: brendan, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
See URL. Shu, can you take this bug? Thanks,

/be

Comment 1

7 years ago
This is fixed in TM tip. I can't seem to assign or close this bug though.

Comment 2

7 years ago
Sorry if this is well known, but may I ask you what do you mean by TM tip? Tracemonkey tip? Thanks.

Comment 3

7 years ago
Yes, exactly.

Comment 4

7 years ago
And where can I find it? Is it a branch or fork or... Thx.

Comment 5

7 years ago
You can do:

> hg  clone http://hg.mozilla.org/tracemonkey/

Narcissus is to be found in tracemonkey/js/narcissus

Comment 6

7 years ago
http://hg.mozilla.org/tracemonkey/rev/1c7d7b849b21
Whiteboard: fixed-in-tracemonkey

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 579230

Updated

7 years ago
Whiteboard: fixed-in-tracemonkey

Comment 8

7 years ago
Tracemonkey is the JavaScript development branch. It is merged into mozilla-central on a regular basis.

Comment 9

7 years ago
Wow, pretty huge rewrite. Basically means that I will redo my port to Python under:
http://github.com/unify/jstools

May I ask you whether you plan further major changes to the parser?

Comment 10

7 years ago
Sebastian, Shu is working on an SSA analysis for Narcissus. The parser refactoring is mostly done. We will add another building (SSABuilder), but most of the existing code should be stable now.
(Reporter)

Comment 11

7 years ago
This bug is fixed, but it is certainly not a dup of bug 579230 "Builder pattern refactor of the narcissus parser." It's a dependent bug, s'all.

/be
Status: RESOLVED → REOPENED
Depends on: 579230
Resolution: DUPLICATE → ---
(Reporter)

Comment 12

7 years ago
Fixed by Shu's recursive descent rewrite for bug 579230.

/be
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

7 years ago
Sebastian, thanks for tweeting about the old ?: bug. Regarding future changes, as Andreas notes the recursive descent parser is pretty stable for the language that it parses -- it is based on SpiderMonkey's parser. However there are more changes to look out for in the future, which will be based on the

http://wiki.ecmascript.org/doku.php?id=harmony:proposals and
http://wiki.ecmascript.org/doku.php?id=strawman:strawman

proposals.

/be
You need to log in before you can comment on or make changes to this bug.