If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Scrolling and rendering glitches when flash is playing

RESOLVED FIXED

Status

()

Core
Graphics
--
major
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: naktinis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Gecko/20100720 Firefox/4.0b2

When an embedded flash is playing (e.g. youtube) it starts blinking with random white areas (not really random, they tend to appear at the edges of depicted objects). Then if I try to scroll, rendering glitches start to appear: a small rendered fragment is repeated many times vertically. If I pause youtube or move focus away from the browser's window, the effects disappear.

I only noticed this in Firefox 4 beta 2 (maybe beta 1 also, not sure). This never happened in earlier versions or in other browsers, so it is probably not a hardware problem.

Reproducible: Always

Steps to Reproduce:
1. Open a site with embedded youtube (could not reproduce it in youtube.com, though)
2. Play the flash video
3. Try scrolling the browser's window
Actual Results:  
Rendering after scrolling was glitched. Youtube movie had white spots (also without scrolling).

Expected Results:  
Scrolling should be smooth and without glitches, flash movie should be without white random spots.
(Reporter)

Comment 1

7 years ago
Created attachment 461922 [details]
Glitched rendering

Comment 2

7 years ago
Could you re-test with http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/ (make sure to back up your profile, current nightly corrupts cookies) to see if this is the same issue as bug 579736?
Component: General → Graphics
Depends on: 579736
QA Contact: general → thebes
Blinking is bug 579676.
I think the smearing on this page in the screenshot will need bug 583115 fixed.
Depends on: 583115, 579676
No longer depends on: 579736
(Reporter)

Comment 4

7 years ago
Seems fixed in the latest build (Gecko/20100802 Minefield/4.0b3pre). Tried a few times to make sure: the problem does not happen in 4.0b3pre (but happens in 4.0b2). I guess we can close this one now and I'll just keep an eye on it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Thanks.  Bug 576143 probably helped with the blinking.
Depends on: 579736, 576143
No longer depends on: 579676, 583115
You need to log in before you can comment on or make changes to this bug.