Location of new windows is incorrect; new windows open off screen

RESOLVED FIXED

Status

()

Firefox
General
--
major
RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: Luke Pacholski, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

In previous versions, new windows were drawn down and to the right, unless the bottom or right side of the screen had been reached, in which case they would be drawn elsewhere, but still on screen. With 4.0b2, new windows always get drawn down and to the right, until the upper left corner of the youngest window is almost to the lower or right edges of the screen. This causes most new windows to be drawn partially off screen if the window size is close to the screen size.

Reproducible: Always

Steps to Reproduce:
1. Start Firefox 4.0b2.
2. Manually size the window so the lower right corner is near the lower right corner of the screen.
3. Hit Ctl-N to open a new window.
4. Repeat 2 & 3 a few times.
Actual Results:  
New windows will continue to be drawn farther and farther off screen.

Expected Results:  
New windows should be positioned entirely on screen.
(Reporter)

Comment 1

8 years ago
This continues to be an issue in 4.0b3.
Severity: normal → major

Comment 2

8 years ago
I confirm the reported behavior.

The behavior occurs on Firef0x 4.0b2 and 4.0b3.

It does not occur on Firefox 4.0b1 or 3.6.8 or prior versions.
(Reporter)

Comment 3

8 years ago
This continues to be an issue in 4.0b4.

Comment 4

8 years ago
Yes, this regression continues to be present in 4.0b4.
(Reporter)

Comment 5

8 years ago
This continues to be an issue in 4.0b5.

Comment 6

8 years ago
Yes, this continues to be an issue in 4.0b5.
(Reporter)

Comment 7

8 years ago
This continues to be an issue in 4.0b6.
(Reporter)

Comment 8

8 years ago
This seems to be fixed in 4.0b7. Can anyone else comment?

Comment 9

8 years ago
(In reply to comment #8)
> This seems to be fixed in 4.0b7. Can anyone else comment?

To me as well, this appears to have been fixed in 4.0b.

Comment 10

8 years ago
[Edit]
To me as well, this appears to have been fixed in 4.0b7.
(Reporter)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.