If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

message display interface won't display messages by date -- insists on threading unrelated messages.

RESOLVED INVALID

Status

Thunderbird
Folder and Message Lists
RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: L A Walsh, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.8.1.24) Gecko/20100228 [BUG:SIC] Lightning/0.9 Thunderbird/2.0.0.24 [BUG:SIC] Mnenhy/0.7.6.666

This is ridiculous.  
Here we are at version 3.1.1 and serious issues like this are still broken in this threaded baloney reader?

What was anyone thinking?  The default client needs to be reverted to a 2.x client until 3.x can _AT LEAST_ support the existing 2.x feature set. 

So far 3.X is still pre-release quality.  It doesn't meet the features set of 2.x.  It should never have been let out the door -- let alone made the default install until that bar was met.  

I can't display messages in Date order -- that's a BASIC of an email client.
Threading is an ***Addon-feature***....if you can't meet the basics, then worrying about "frills" like threading is ridiculous -- but worse -- threading worked FINE in 2.x.  In 3.x, I don't even have, what I and others consider to be basic features like Thread vis working.  

I even told it NOT to display the threads column -- but I still can't sort by date.  It takes every message with a similar subject and groups them under 1 thread.  That's absurd.  They are separate status messages sent daily -- they are not a thread. 

When I see all those messaged grouped together under date view -- it's a bug -- and I want to delete all the redundant messages -- because I know they only come in once/day -- I should never see 2 of them right next to each other -- they are sprinkled throughout the folder unless I click sort-by-subject.  But never, are they a thread.  No one is replying to anyone else.

Reproducible: Always

Steps to Reproduce:
1.  have status messages sent daily for n months with same subject sent to normal inbox; 
2.  try to display your box by date so status messages are interspersed, by date, with rest of messages; OR try to display message in order received.
3.
Actual Results:  
you don't see status messages shown along timeline.  Timeline view of messages  -- th 2nd most basic of views, in order received (most basic view) is unavailable.



Expected Results:  
Most basic views should be verified to work before all others.

If they don't work, the product doesn't ship as failing basic compatibility tests.

Not being able to display in date or order received is horrible and can easily cause loss data as user is unable to find email as it comes in.

Comment 1

7 years ago
view | sort by | unthreaded, then sort by date or order received isn't working for you? It works fine here...
In fact, iirc threading behavior has not changed in version 3. Are you  using "grouped by"?

I don't understand your comment about http://threadvis.mozdev.org/ - their website cites it is compatible with v3.1. But even if it isn't working, you understand it's the add-on author's responsibility to make it work for release X, not Thunderbird's.

L A Walsh, you have a long enough history in bugzilla to know that you should  limit bug reports to one issue. Please do so in the future, and limit comments to bug material. Non-bug material is for http://getsatisfaction.com/mozilla_messaging/ ... Thanks.

And please don't abuse severity. see https://bugzilla.mozilla.org/page.cgi?id=fields.html#importance for definition of Critical
Severity: critical → normal
Summary: message display interface won't display messages by date -- insists on threading unrelated messages. inteface is buggy. Version 3 is not ready for prime time → message display interface won't display messages by date -- insists on threading unrelated messages.
Version: unspecified → 3.1
lacks response.
=> incomplete
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

6 years ago
I backsteped to 2.x, as 3.x kept thrashing my disk space.
(explained elsewhere, bug I don't need 4G of imap email copied 5 times on 
5 home accounts where I can run tb.

.
Resolution: INCOMPLETE → INVALID
You need to log in before you can comment on or make changes to this bug.