If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

SeaMonkey
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Rocco Stilo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3pre) Gecko/20100802 SeaMonkey/2.1a3pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3pre) Gecko/20100802 SeaMonkey/2.1a3pre

SeaMonkey 2.1 alpha doesn't load pdf pages on Mac OS X, both Power PC with Leopard and Intel with Snow Leopard. After loading, pages are blank. Under 2.0.6 and 2.0.7, even in beta, it's all OK.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
I was forgotting: I use PDF Browser plugin to see pdf pages within SeaMonkey. I can always save pages and open later.
In both 2.0.7 and 2.1a,try the following:
1. In "SeaMonkey => Preferences => Browser => Helper Applications", is there an entry (or several) for "PDF document"? What does it (do they) say?
2. Type about:config in the URL bar then hit Enter
3. If you get a warning screen saying that this might void your warranty, answer "I'll be cautious" or whatever it is
4. If the preference plugin.expose_full_path is false, double-click it to make it true. If it is not present at its alphabetical place, use Right-Click => New => Boolean to create it, with the value True.
5. Type about:plugins in the URL bar and hit Enter.
6. Notice any differences between SeaMonkey 2.0 and 2.1 in the Adobe Reader entry? Is it present? What version? What full path? Is it enabled?
7. Any other plugin enabled for pdf files? Name? Version? Path?
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> In both 2.0.7 and 2.1a,try the following:
> 1. In "SeaMonkey => Preferences => Browser => Helper Applications", is there an
> entry (or several) for "PDF document"? What does it (do they) say?
> 2. Type about:config in the URL bar then hit Enter
> 3. If you get a warning screen saying that this might void your warranty,
> answer "I'll be cautious" or whatever it is
> 4. If the preference plugin.expose_full_path is false, double-click it to make
> it true. If it is not present at its alphabetical place, use Right-Click => New
> => Boolean to create it, with the value True.
> 5. Type about:plugins in the URL bar and hit Enter.
> 6. Notice any differences between SeaMonkey 2.0 and 2.1 in the Adobe Reader
> entry? Is it present? What version? What full path? Is it enabled?
> 7. Any other plugin enabled for pdf files? Name? Version? Path?

Made it "true", but... nothing. PDF pages are always blank. Plugin is enabled. Versions are the same.
(Reporter)

Comment 4

7 years ago
Perhaps, I,ve found. 

As stated here: http://www.schubert-it.com/pluginpdf/

PDF Browser Plugin only works in 32-bit mode of Safari. To switch to 32-bit mode select Safari in Finder, choose "Get Info" in the "File" menu and select "Open in 32-bit mode".

This maybe true for Seamonkey, too. Furthermore, the site states also that compatible-browsers are: Safari, Firefox, iCab, OmniWeb.
In reply to comment #3: that about:config setting was for debugging, so you could give better answers to my questions under 6 and 7 of comment #2 (which you still haven't answered).

In reply to comment #4: any plugin that can be used with Firefox can be used with SeaMonkey, it's just that some companies don't know (yet) that SeaMonkey even exists.

Well, does it make a difference if you try to run SeaMonkey in 32-bit mode?
(Reporter)

Comment 6

7 years ago
> Well, does it make a difference if you try to run SeaMonkey in 32-bit mode?

I don't see in Get Info window for SeaMonket the checkbox for 32-bit mode...
(In reply to comment #6)
> > Well, does it make a difference if you try to run SeaMonkey in 32-bit mode?
> 
> I don't see in Get Info window for SeaMonket the checkbox for 32-bit mode...

Hm, after some research I see only one SeaMonkey series of builds for the Mac (unlike Linux, where there is linux-i686 and linux-x86_64). Maybe the Mac build of SeaMonkey (or at least the Intel half of the Universal Binary) is 32-bit only?
(Reporter)

Comment 8

7 years ago
Latest build fixed the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 9

7 years ago
I'm re-resolving this as worksforme, since we don't know what caused this to
work again ("Fixed" is reserved for bugs where a known patch fixed the
problem).
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.