Closed Bug 58380 Opened 20 years ago Closed 14 years ago

Inbox as a standard "virtual folder"

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

enhancement
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: netdragon, Unassigned)

References

Details

You can have all drafts, sent mail, etc go to a folder in Local folders, but
there is no local folders/Inbox, and way to have all incoming mail sent to that
box. You probably have to set a filter, and that will be too hard for the
average person.
I agree with the submitter. This is the same feature I requested in bug 30057.

I'll mark it as a duplicate. If you feel that these two RFE's are not the same, 
feel free to reopen.

*** This bug has been marked as a duplicate of 30057 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
the reason "Local Folders" doesn't have an inbox (by default) is because there
is no "incoming" server for it.

you could always create a new folder called "Inbox" on "Local Folders" and
filter all your mail into it.

what you really want is a feature called "virtual folders".  you could have a
"virtual folder" for all new mail across all accounts.

http://bugzilla.mozilla.org/show_bug.cgi?id=11051
Then why is there a Local Folders in the first place? You can't delete it, so 
they just sit there...useless.
Sounds good to me. Maybe if you could make a list of all folders you want email 
to be sent to from each account as opposed to just one. Deleting mail in one 
deletes the mail from the server (if you have that set). 

This could - I guess - use virtual folders or not. The important thing is that 
if you delete the mail in one folder, it doesn't delete the mail in the others.
jerry:  here's some of the reasons why we have "Local Folders"

1)  you only use imap, and you are off-line.  where do you save drafts or unsent
messages?
2)  you only read news.  where do you save a copy of your sent messages?
VERIFIED DUP.
Status: RESOLVED → VERIFIED
OK. I am changing this bug Summary to mean a standard Virtual Folder 
named "Inbox". I am not sure if this would be best in the "Local folders" or in 
a seperate folder. Marking it a dependancy of bug 30057. I do not think it is a 
duplicate, though because it is more specific.
Status: VERIFIED → UNCONFIRMED
Depends on: 30057
Resolution: DUPLICATE → ---
Summary: Local folders/Inbox can't get mail from every account → Inbox as a standard "virtual folder"
Woops. I meant 11051.
Depends on: vfolders
No longer depends on: 30057
how is that different from bug 30057?
Because 30057 doesn't mention virtual folders.
Fine... I think this maybe should be a dupe... but since you insist that it's
not, I'll confirm it.

Confirming, severity -> enh
Severity: normal → enhancement
Priority: P3 → --
oops... meant to actually confirm it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mass removing self from CC list.
Product: Browser → Seamonkey
Assignee: sspitzer → mail
Is there anything left to do here, given that bug 11051 is fixed?
Component: MailNews: Account Manager → MailNews: Main Mail Window
QA Contact: esther
now that we have the global inbox, this is done.
Status: NEW → RESOLVED
Closed: 20 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.