Body filter quick search doesn't work in conversation view

VERIFIED DUPLICATE of bug 523572

Status

VERIFIED DUPLICATE of bug 523572
8 years ago
8 years ago

People

(Reporter: jopromail-mfg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.7) Gecko/20100713 Lightning/1.0b2 Thunderbird/3.1.1

When viewing messages in a threaded view, that is only the messages belonging to a specific thread are visible, the body filter quick search function doesn't work. It is possible to use the from, to and subject quick search filters. The search function finds the corresponding messages whereas it doesn't find any messages if only the body filter is used even if some of the messages in the threaded view contain the word which was entered into the search field.

Reproducible: Always

Steps to Reproduce:
1. Open a threaded view. Right click on any message and select "show this message in threaded view" (or something similar; unfortunately I don't have an English Thunderbird version installed).
2. Enter a term into the quick search field from which you know that it is contained in one of the messages listed below.
3. Only select the body content filter
Actual Results:  
No message found

Expected Results:  
The messages containing the text in the quick search field should be found.
Confirming on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b3pre) Gecko/20100802 Shredder/3.2a1pre
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Summary: Body filter quick search in threaded view doesn't work → Body filter quick search doesn't work in conversation view
Protz any interest in this one ?

Comment 3

8 years ago
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.9.2.8) Gecko/20100802 Thunderbird/3.1.2
Assuming "view in conversation" and "open as list" ultimately trigger the same view, this is a duplicate of bug 523572
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 523572

Comment 5

8 years ago
(In reply to comment #4)
> Assuming "view in conversation" and "open as list" ultimately trigger the same
> view, 

Yes, I believe so. thanks Thomas.
Status: RESOLVED → VERIFIED
Ludo: sorry about the late reply, but I don't think this intersects much with the areas I'm familiar with. I don't think it has much to do with "view in conversation"...
You need to log in before you can comment on or make changes to this bug.