Closed Bug 583851 Opened 12 years ago Closed 11 years ago

awesomebar suggests non-matching sites when "www." is typed

Categories

(Firefox :: Address Bar, defect)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 585971

People

(Reporter: jack, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100802 Minefield/4.0b3pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100802 Minefield/4.0b3pre (.NET CLR 3.5.30729)

Awesomebar is ignoring what I type and making it difficult to use.

Reproducible: Always

Steps to Reproduce:
- Two related web sites exist: www.example.com and special.example.com.
- visit and/or bookmark many pages on both sites.  The content is not the same.
- In the Location bar you type "www.example whatever" and both sites have a few pages in the history that matches "whatever".

Actual Results:  
Pages that match "special.example whatever" are usually the top selection, and often pages matching "www.example" are nowhere in its selections.

Expected Results:  
A page that actually matches "www.example whatever" should be suggested.

Failing that, it should at least use the "browser.fixup.alternate.prefix" value instead of a hard-coded "www."  That way I could change it and work around the problem.

To make the example extra delicious, assume you are a web developer and one site is your intranet site, www.company-intranet.com and the other site is your development site, dev.company-intranet.com, and the entire set of URLs can coincide except for the "www" or "dev" part, and the "data" is completely different.  Now you're typing "www.company etc" thirty times a day (because it *used to be* the best way to get to the page you want) and it suggests about a dozen pages matching "dev.company etc" every single time.
I don't use browser.urlbar.autoFill, and I think that's what bug 577235 is about, so this may or may not be the same bug, under the surface.

Apparently this was done on purpose by bug 461483.  I humbly disagree with how that bug was addressed.  The motivation behind 461483 seems to be that there is a problem when typing "www" in the awesomebar doesn't bring up matches for URLs that don't have "www" in them.  I doubt these same people would think the GPS is at fault if they type "street" instead of "avenue" or "boulevard" and it navigates them to some other place that they accidentally asked to go.  Not every website has "www" in its name and that's just a fact.  "http://" is a protocol designation, one of only a few that are relevant to firefox, but "www" is just a weird old habit of people who chose web server names.  That is why I think bug 461483 should be reversed.
the other bug is already confirmed.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 585971
You need to log in before you can comment on or make changes to this bug.