Closed Bug 583859 Opened 9 years ago Closed 8 years ago

black text displays blurred/green outlined

Categories

(Firefox :: General, defect)

x86_64
Windows 8
defect
Not set

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: steve, Unassigned)

References

()

Details

Attachments

(5 files)

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

as an example, on the above website, the text elements on the pages render incorrectly.  They should be straightforward black text but render blurry and with green blurry outlines.  Compare the same site in other browsers or Firefox 3.

Reproducible: Always

Steps to Reproduce:
1. visit above linked website.
2.
3.
Actual Results:  
Text displays incorrectly as described.

Expected Results:  
Displayed the text correctly!
Please attach a screenshot of the problem with the "add an attachment" link above
Blocks: 564991
Depends on: 579276
Is this Bug 549661?

Also, slightly OT,  I think extreme cleartype settings can exacerbate this issue.

Check the registry key here http://msdn.microsoft.com/en-us/library/aa970267.aspx
and see if there is anything set there, maybe TextContrastLevel set really high.
Thanks for response, not sure if it is cleartype settings as I have no problems elsewhere and until using Firefox 4 beta 2 have not seen this issue on any web page.  See attached screenshot of registry settings.
(In reply to comment #5)
> Created attachment 462371 [details]
> Registry settings for text display

Try EnhancedContrast at 0. You may need a restart afterwards though, I can't remember.

If the text still looks funny after that then I would be pretty sure it's bug 549661 which is really a problem with DirectX. Check out some of the testcases in there as the artifacts you are experiencing are similar.
Thanks, have done as you suggested and re-booted the machine but the text looks the same.  So maybe it is the other bug reported, although that refers to light text on a dark background as opposed to black text on white background as here, furthermore having looked at the site mentioned in that post, it display ok in every browser I've tried.  

However, my display problem doesn't affect any other browser or earlier versions of Firefox e.g. the latest official release of Firefox, where the text looks fine - just as it should, it only displays incorrectly in Firefox 4 - which to my non technical mind means its an issue to be sorted for development of Firefox 4 (the reason I posted the bug).
I see the same issue at http://oss.netfarm.it/mplayer-win32.php, this is with a new profile. Turning on DW seems to actually fix the issue.
I'm seeing this same problem on Firefox 4 beta 6 on Windows 7 64bit (Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6). I also did a little testing and found that this happens on these conditions:

- the text is in gray color (at least #777).
- the body has a background image.
- the background image attachment is 'fixed'.
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco
Steve, Lim Chee Aun ...

(In reply to Tyler Downer [Triage] (away) from comment #13)
>...
> can you please update this bug with your results?
Whiteboard: [closeme 2012-02-29]
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-02-29]
It does now appear to be fixed for me, although using a much later version of FF and on Win 8 Consumer Preview.
OS: Windows 7 → Windows 8
Version: 4.0 Branch → unspecified
You need to log in before you can comment on or make changes to this bug.