Menus are corrupt when using WinTV software in full screen mode.

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
18 years ago
9 years ago

People

(Reporter: Manuel Nickschas, Unassigned)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; m18) Gecko/20001027
BuildID:    several, at least since Netscape PR 3 until now

Using the Hauppauge WinTV software in full screen mode will cause Mozilla's
menus to be corrupt. This happens in all open browser windows (including
Mail/News). Not all menus are corrupt, the number varies (but "Tasks" and
"Bookmarks" seem to be always corrupt).

The corrupt menus display as empty rectangles, sometimes behind the toolbars
(i.e. there is only the very top visible). The menu entries, at least some of
them, still seem to work, but they're not where they're supposed to be. Opening
a new browser window will help, i.e. in newly opened browser and mail windows
all menus are OK.

Reproducible: Always
Steps to Reproduce:
1.) Start Mozilla (of course! ;-))
2.) Start WinTV2k by Hauppauge to watch TV.
3.) Enter full screen mode.
4.) VERY IMPORTANT: Do anything to invoke WinTV's OSD, i.e. changing volume or
channel
5.) Leave full screen mode and go back to Mozilla


Actual Results:  Half of your menus in the open browser and mail windows are
missing, you get empty rectangles (sometimes - usually - overlapped by the
toolbars). The rectangles don't seem to have the original size, but I can't say
for sure. Clicking within such an empty rectangle usually gives an result, so
there still seem to be some invisible menu entries.

Expected Results:  Displaying menus.

This already happened in the first Mozilla version I've used (Netscape PR3) and
it still exists in nightly build of 10/28.

Comment 1

18 years ago
how much free memory do you have when this happens?
(Reporter)

Comment 2

18 years ago
Since I can reproduce this error every time, after a fresh reboot and after some
hours of uptime, I don't believe it has something to do with free memory.
Anyway, I've just checked, and I have constantly (before and after using WinTV,
therefore corrupting the menus) about 20 MB of unused physical memory.

BTW, there seems to be kind of an order in which the menus vanish: The bookmarks
menu in browser window seems alwys be to be the first, after that others follow
in browser and mail windows.

And I have checked that the menu items are still there (clicking gives the
expected result), but they won't be showed (I get empty rectangles).

I also could include a screenshot, if it helps you.

An additional hint: Applying a new theme restores the menus in all browser
windows. However, switching WinTV to full screen mode and showing the OSD after
that results again in corrupt menus, in both themes.

Comment 3

18 years ago
a screenshot can help

i've seen menus go dead when memory gets low.
(Reporter)

Comment 4

18 years ago
Created attachment 18321 [details]
Screenshot that shows corrupt menu in browser window.
(Reporter)

Comment 5

18 years ago
Created attachment 18322 [details]
Screenshot that shows corrupt menu in mail/news window.
(Reporter)

Comment 6

18 years ago
Note that the rectangles partly (!) are behind the toolbars, and that in the
second screenshot the rectangle is not where it is supposed to be.

I have 256 MB of RAM, plenty of swap file left, and as I said, I can reproduce
the bug on a newly started system with lots of RAM free... no way there I
assume... ;-)

Comment 7

18 years ago
updating component and setting bug status to new.
Assignee: asa → ben
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Apps: GUI Features
Ever confirmed: true
QA Contact: doronr → sairuh
hrm, xp menus...? if not, punt back.
Assignee: ben → pinkerton
Component: XP Apps: GUI Features → XP Toolkit/Widgets: Menus
QA Contact: sairuh → jrgm

Comment 9

18 years ago
for what it's worth, I get this too without the WinTv software after loading
memory intensive apps (like Homesite) on win98 (could not repro on linux)
Status: NEW → ASSIGNED
Target Milestone: --- → Future
(Reporter)

Comment 10

18 years ago
I could reproduce this bug under Windows 2000.
OS: Windows ME → Windows 2000

Comment 11

18 years ago
reporter: please don't bother changing os from Windows X to Windows Y, unless 
you can no longer reproduce it on X. The system we have does not really work 
for the Win32 platform series, and maybe in some future bugzilla we will fix 
it.

Comment 12

17 years ago
are you using WINTV in Overlay FullScreen Mode or Primary Full Screen mode? This
might have something to do with it. In Overlay mode, the resolution of the
computer isn't touched. (everything is in the overlay layer) But in "Primary"
mode, the resolution of the computer changes to 640x480 which could screw up the
menus.

On another note, I cannot reproduce this on my machine with Wintv in either
mode, so it might be fixed with a newer build. Reporter, could you try seeing if
you can reproduce this problem anymore.

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets

Comment 13

9 years ago
reporter appears to be gone.
closing WFM on strength of comment 12
Assignee: mikepinkerton → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.