If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

some bookmarks fail to appear in Minefield 4.0b3, which do appear in 3.6.8

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: David Jackson, Unassigned)

Tracking

3.6 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

I have noticed that not all of the bookmarks from my Firefox 3.6.8 installation appear when I open Minefield 4.0b3. In some cases, bookmarks or folders are missing, and in some cases empty subfolders appear (instead of bookmark-filled subfolders).  It is also the case that setting a bookmark has begun to fail in recent Minefield nightlies.  

Reproducible: Always

Steps to Reproduce:
1. Scan all bookmarks
2. Some bookmarks are missing (maybe preferentially the more recent ones)
3. Try to set bookmark
4. Nothing is added to Minefield bookmark list.
Actual Results:  
some existing bookmarks do not appear, and setting new bookmarks sometimes fails in Minefield

Expected Results:  
All bookmarks visible in Firefox should also show up in Minefield.  Similarly, setting a bookmark should add that bookmark to the selected folder in Minefield. 

Using default theme and minimal extension list with Minefield.
(Reporter)

Comment 1

7 years ago
Created attachment 462427 [details]
screenshot showing example bookmarks missing from Minefield

Procedure was to startup Firefox, take a screenshot of a region of the bookmarks file, close Firefox, open Minefield and take a screenshot of the same region of bookmarks.  Missing bookmarks are in red rectangle and appear to map to one site in the Minefield bookmark display.
(Reporter)

Updated

7 years ago
Version: unspecified → Trunk
(Reporter)

Comment 2

7 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
> rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
> Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US;
> rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8
> 
Affected builds are Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b3pre) Gecko/20100803 Minefield/4.0b3pre ID:20100803045416 and other 4.0b3 builds,  NOT Firefox 3.6.8.
(Reporter)

Comment 3

7 years ago
Bookmarks seem to have returned in 4.0b4.  This may be resolved.
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> Bookmarks seem to have returned in 4.0b4.  This may be resolved.

I may have spoken too soon.  The disappearing bookmarks don't appear in Windows XP, Minefield 4.0b4, BUT I need to recheck on Mac OS X 10.6.4 - I believe I only ever saw the absent bookmarks in OS X, so rechecking is important.
Still reproduceable in Firefox 4 final?
Ensure this is not somehow caused by some add-on in safe mode: http://support.mozilla.com/kb/Safe+Mode
(Reporter)

Comment 6

7 years ago
(In reply to comment #5)
> Still reproduceable in Firefox 4 final?
> Ensure this is not somehow caused by some add-on in safe mode:
> http://support.mozilla.com/kb/Safe+Mode

I have not seen disappearing bookmarks since early last fall.  FF4 does not have this old bug.
Thanks, glad to hear that!
The report doesn't have much information to reproduce on 3.6 or evaluate if that would be an easy fix, and I've not seen other reports regarding this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Version: Trunk → 3.6 Branch
You need to log in before you can comment on or make changes to this bug.