colspan produces incorrect alignment in XHTML documents.

VERIFIED INVALID

Status

()

Core
Layout: Tables
P3
normal
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: Ian Hutchinson, Assigned: karnaze (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
The following table renders incorrect alignment when in a doctype of XHTML
but it is correct in a doctype of HTML:

<table border="1">
<tr><td nowrap="nowrap" align="right"> Row 1 Cell 1 Right Aligned
</td><td nowrap="nowrap" align="left"> Cell 2, Left aligned</td></tr>
<tr><td nowrap="nowrap" align="right" colspan="0">
Row 2 Cell 1 Right aligned
</td><td nowrap="nowrap" align="left"> Row 2 Cell 2</td></tr></table>

The problem is that colspan="0" is being incorrectly rendered as
colspan="2" in XHTML.

[Milestone 18 linux binary.]

Comment 1

17 years ago
I see the problem in the Mozilla Build #2000103104 M18 Trunk build on Win 98.
Changing to ALL and marking as NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

17 years ago
Still seeing this on Mozilla Build 2001012205 Win32 build.

Comment 3

17 years ago
QA contact update
QA Contact: chrisd → amar

Comment 4

17 years ago
>The problem is that colspan="0" is being incorrectly rendered as
>colspan="2" in XHTML.

just a short quote from the html spec:

This attribute specifies the number of columns spanned by the current cell. The
default value of this attribute is one ("1"). The value zero ("0") means that
the cell spans all columns from the current column to the last column of the
column group (COLGROUP) in which the cell is defined.

We do so in strict mode and behave different in quirks mode where colspan <=0
are treated as colspan=1.

As we treat xhtml documents in standard mode mozilla behaves as required by the
spec. Marking invalid.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
 Since this bug invalid with wrong HTML I am marking verified ...
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.