can not install on red hat 7.0

VERIFIED INVALID

Status

SeaMonkey
Installer
P3
critical
VERIFIED INVALID
18 years ago
13 years ago

People

(Reporter: jon655321, Assigned: Sean Su)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)
BuildID:    M18

can not install on red hat 7.0

Reproducible: Always
Steps to Reproduce:
1.install into /user/local/mozilla
2../mozilla
3.

Actual Results:  ./run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=.
  LD_LIBRARY_PATH=.
     LIBRARY_PATH=.:./components
       SHLIB_PATH=.
          LIBPATH=.
       ADDON_PATH=.
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
./run-mozilla.sh: line 72:  8090 Segmentation fault      $prog ${1+"$@"}
                            

Expected Results:  installed

Updated

18 years ago
QA Contact: gemal → gbush

Comment 1

18 years ago
 This may be due to compatability problems in Redhat 7.0's support for the
Redhat 6.2 C++ environment. The C++ binary interface is still in flux, so the
'native' C++ ABI in 7.0 is incompatable with the 6.2 C++ ABI. While Redhat 7.0
appears to supply a compatability layer (in the compat-libstdc++-6.2-2.9.0.9
RPM), it may not work well enough for Mozilla's purposes.

Comment 2

18 years ago
jon, did you run mozilla once as root?  did you delete your profile directory
and all the other good pre-install fun?

Comment 3

18 years ago
works for me rh7.0 linux build 2000103008.
try installing and running it the first time as root ....

Comment 4

18 years ago
must run ./regxpcom && ./regchrome before becoming someone other than the 
installer user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 5

17 years ago
verified invalid
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.