If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Fix the ftp and file trees; add a min-height for <treerow>

VERIFIED FIXED in M18

Status

SeaMonkey
Themes
P2
normal
VERIFIED FIXED
17 years ago
9 years ago

People

(Reporter: John Morrison, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm++] r=bryner, a=hyatt)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Currently, in the skin for directory.xul, which is the tree for ftp://
and file:// listings, the icons for folders, loading and files have
different heights.

This leads to the rows dynamically resizing on certain conditions as the 
loading icon (the spinning arrows) kicks in during the load. Per hyatt,
this puts a lot of stress on the tree code and can lead to situations 
where the child documents of folders are not displayed. 

In the interest of making this tree more stable, we need to add a rule
to modern/blue/classic directory.css that will force the treerows to 
have a min-height of 19px [this is the height that the rows will attain
after the spinning icon kicks in].

This is a very low-risk fix, which can only have an affect on the ftp://
and file:// trees since this CSS is not loaded by any other XUL file in 
the product. [As a side-benefit, it even looks better, although the point
of this bug is to get more stable behaviour at very low cost/risk].

I will attach a patch that makes this change (essentially it's a one-liner
times three skins).

Nominating RTM -- definite end-user benefit, very low risk.

cc: ben as skins owner, 
cc: evaughan since he has a limbo bug that affects the same directory.css 
(but his change is not in any way in conflict with this change).
(Reporter)

Comment 1

17 years ago
Created attachment 18278 [details] [diff] [review]
patch; add 'treerow{min-height:19px}' to directory.css (times three)
(Reporter)

Updated

17 years ago
Keywords: rtm

Comment 2

17 years ago
Marking rtm need info since this is apparent data loss with no obvious
workaround, and the fix is so safe and limited.
Priority: P3 → P2
Whiteboard: [rtm need info]
Target Milestone: --- → M18
(Assignee)

Comment 3

17 years ago
r=bryner on jrgm's patch.  hyatt, sr?

Status: NEW → ASSIGNED

Updated

17 years ago
Whiteboard: [rtm need info] → [rtm need info] r=bryner, NEED SR=

Comment 4

17 years ago
This needs a SR immediately, if it is going to get in.

cc:ing waterson.

Comment 5

17 years ago
The last line of the patch appears to put a } after the line

	\ No newline at end of file

can that possibly be correct?

Can this change ever have any effect on any tree other than the one you're fixing?
(Reporter)

Comment 6

17 years ago
Created attachment 18579 [details] [diff] [review]
patch; no newline adjustment
(Reporter)

Comment 7

17 years ago
Actually the patch was showing the difference between '}' and '}\n', but 
looks like an addition. (Sorry, my editor insists on adding the newline, so
I switched to notepad to avoid the correction).

This file, directory.css, is pulled in by only one file: directory.xul, which
implements the tree for ftp:// and file:// directory listings. So, no, this 
cannot affect any other tree. This is a very localized, low-risk, solid benefit
fix.

Comment 8

17 years ago
a=hyatt
Whiteboard: [rtm need info] r=bryner, NEED SR= → [rtm+]

Updated

17 years ago
Whiteboard: [rtm+] → [rtm+] r=bryner, a=hyatt
(Assignee)

Comment 9

17 years ago
checked in on trunk, leaving bug open until decision is made for rtm++

Comment 10

17 years ago
PDT marking [rtm++]
Whiteboard: [rtm+] r=bryner, a=hyatt → [rtm++] r=bryner, a=hyatt

Comment 11

17 years ago
jrgm: will you be available to test this patch / fix on the branch builds from
Saturday morning (once patch is checked in) to make sure other tree areas don't
have regressions and that ftp trees work fine?  Thanks!
(Reporter)

Comment 12

17 years ago
Sure, I can come in and do that. Just to be clear: this patch can not affect
any other tree, except for the single file "directory.xul" which includes 
this .css file:
      http://lxr.mozilla.org/seamonkey/search?string=directory.css
      http://lxr.mozilla.org/seamonkey/search?string=directory.xul
which means only the ftp:// and file:// directory viewers.

Nonetheless, I will be looking at the various trees for general sanity 
checking. (By the way, I have already made this .css change in a copy of 
the branch chrome mac/linux/win32 in both skins, and it works fine).
(Assignee)

Comment 13

17 years ago
checked in on branch
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

17 years ago
verified with 2000110409 MN6 branch mac/linux/win32 -- row heights have a 
min-height of 19px, avoiding the dynamic resize of the rows. Previously 
verified on trunk.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.