Closed Bug 584417 Opened 12 years ago Closed 12 years ago

Awesome bar tends to result in "i'm feeling lucky" instead of searching preferred search engine

Categories

(Firefox :: Address Bar, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 585870

People

(Reporter: guy.pyrzak, Unassigned)

Details

I like the updates to the awesomebar but if I type in a criteria that isn't in a tab, or isn't in my history, the awesomebar tends to go to "i'm feeling lucky" instead of just showing me possible search results. The old awesomebar used to just do a google search. I'd really like it if the awesomebar would just show me search results, because apparently I'm not very lucky.

I understand if this is a feature and not a bug, in which case I'll start writing/looking for an extension now.
Try going into about:config and changing keyword.url from

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

to

http://www.google.com/search?q=

Any difference?
yes it did!
Is this resolved then?
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
OS: Mac OS X → Windows 7
Resolution: FIXED → WONTFIX
Well, the about:config fix did fix the problem, but shouldn't the URL suggested in comment 1, be the default one instead of the one that is currently set or is the new interaction expected?
How about the solution proposed in the following bug?
https://bugzilla.mozilla.org/show_bug.cgi?id=585870

Please feel free to edit/comment/critique it.
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 585870
You need to log in before you can comment on or make changes to this bug.