Closed Bug 584471 Opened 10 years ago Closed 9 years ago

Turn fakelibs (linking directly to object files rather than intermediate static libraries) on on Mac

Categories

(Firefox Build System :: General, defect)

All
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 584474

People

(Reporter: khuey, Unassigned)

References

Details

Attachments

(1 file)

No description provided.
Attached patch PatchSplinter Review
This is all it takes to turn it on.  Question is whether anything else needs to be fixed.
Tryserver says we choke at 

rm -f libalerts_s.dylib
/bin/sh: -c: line 0: syntax error near unexpected token `;'
/bin/sh: -c: line 0: `for lib in growl/libgrowl_s.a ; do ar x ${lib}; ; done'
make[8]: *** [libalerts_s.dylib] Error 2
make[7]: *** [libs] Error 2
make[6]: *** [tools] Error 2
make[5]: *** [components_tools] Error 2
make[4]: *** [tools_tier_platform] Error 2
make[3]: *** [tier_platform] Error 2
make[2]: *** [default] Error 2
make[1]: *** [build] Error 2
make: *** [build] Error 2
program finished with exit code 2

http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTry/1281417267.1281422588.16866.gz&fulltext=1
That'd be this line here failing:
http://mxr.mozilla.org/mozilla-central/source/config/rules.mk#1216

because $(CLEANUP2) is empty.
Actually it's possible that it's CLEANUP1 from the definition of SUB_LOBJS. We should probably just define CLEANUP1 and CLEANUP2 to be true in that block and see if it works.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584474
No longer blocks: 535897
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.