Intermittent failure in content/media/test/test_access_control.html | Can load when redirected to subdomain with allow-origin (element in document) - got "error", expected "loadeddata" (followed by many similar failures)

RESOLVED DUPLICATE of bug 584495

Status

()

RESOLVED DUPLICATE of bug 584495
8 years ago
8 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1280956368.1280958061.28259.gz&fulltext=1
Rev3 Fedora 12 mozilla-central debug test mochitests-1/5 on 2010/08/04 14:12:48

48104 INFO TEST-START | /tests/content/media/test/test_access_control.html
++DOMWINDOW == 41 (0x9bd5958) [serial = 1418] [outer = 0xa2308e0]
pldhash: for the table at address 0xdbcc9b8, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 0xdbcc950 == 16
++DOMWINDOW == 42 (0xdd0da30) [serial = 1419] [outer = (nil)]
++DOMWINDOW == 43 (0xd25cf90) [serial = 1420] [outer = 0xdd0d9f8]
pldhash: for the table at address 0xb8e32d0, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 0xb8e3268 == 17
++DOMWINDOW == 44 (0xcbff810) [serial = 1421] [outer = (nil)]
pldhash: for the table at address 0xbc52ba8, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 0xbc52b40 == 18
++DOMWINDOW == 45 (0xcb38a48) [serial = 1422] [outer = (nil)]
pldhash: for the table at address 0xc9f1300, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 0xc9f1298 == 19
++DOMWINDOW == 46 (0xdeab200) [serial = 1423] [outer = (nil)]
WARNING: Subdocument container has no frame: file /builds/slave/mozilla-central-linux-debug/build/layout/base/nsDocumentViewer.cpp, line 2427
++DOMWINDOW == 47 (0xb389b18) [serial = 1424] [outer = 0xcbff7d8]
WARNING: Subdocument container has no frame: file /builds/slave/mozilla-central-linux-debug/build/layout/base/nsDocumentViewer.cpp, line 2427
++DOMWINDOW == 48 (0xe04e4e8) [serial = 1425] [outer = 0xcb38a10]
++DOMWINDOW == 49 (0xc8b0f28) [serial = 1426] [outer = 0xdeab1c8]
++DOMWINDOW == 50 (0xf092878) [serial = 1427] [outer = 0xdeab1c8]
--DOMWINDOW == 49 (0xc8b0f28) [serial = 1426] [outer = 0xdeab1c8] [url = about:blank]
--DOMWINDOW == 48 (0xccc0dc0) [serial = 1393] [outer = 0xc297e30] [url = http://mochi.test:8888/tests/content/html/document/test/bug499092.html]
--DOMWINDOW == 47 (0xc297e68) [serial = 1392] [outer = (nil)] [url = http://mochi.test:8888/tests/content/html/document/test/bug499092.html]
--DOMWINDOW == 46 (0xc7b4eb0) [serial = 1391] [outer = 0xcc40870] [url = http://mochi.test:8888/tests/content/html/document/test/bug499092.xml]
--DOMWINDOW == 45 (0xcc408a8) [serial = 1390] [outer = (nil)] [url = http://mochi.test:8888/tests/content/html/document/test/bug499092.xml]
--DOMWINDOW == 44 (0xc005a28) [serial = 1417] [outer = 0xa2308e0] [url = http://mochi.test:8888/tests/content/html/document/test/test_viewport.html]
--DOMWINDOW == 43 (0xbbd4d28) [serial = 1416] [outer = 0xa2308e0] [url = http://mochi.test:8888/tests/content/html/document/test/test_form-parsing.html]
--DOMWINDOW == 42 (0xccdaec0) [serial = 1415] [outer = 0xe06be00] [url = about:blank]
--DOMWINDOW == 41 (0xe4cfbe8) [serial = 1414] [outer = 0xbee2100] [url = about:blank]
--DOCSHELL 0xc7c02f0 == 18
--DOMWINDOW == 40 (0xe06be38) [serial = 1413] [outer = (nil)] [url = about:blank]
--DOCSHELL 0xbbb7e10 == 17
--DOMWINDOW == 39 (0xbee2138) [serial = 1412] [outer = (nil)] [url = about:blank]
--DOMWINDOW == 38 (0xcdc4658) [serial = 1410] [outer = 0xd8614e8] [url = javascript:'<body%20onload="this.onerror%20=%20parent.onerror;%20parent.disp()"></body>']
--DOMWINDOW == 37 (0xe14db88) [serial = 1409] [outer = 0xa959e78] [url = javascript:'<body%20onload="this.onerror%20=%20parent.onerror;%20parent.disp(self)"></body>']
--DOCSHELL 0xd7b2cb8 == 16
--DOCSHELL 0xc5c3070 == 15
--DOMWINDOW == 36 (0xc2f1890) [serial = 1408] [outer = 0xd8614e8] [url = about:blank]
--DOMWINDOW == 35 (0xe0be100) [serial = 1407] [outer = 0xa959e78] [url = about:blank]
--DOMWINDOW == 34 (0xd861520) [serial = 1406] [outer = (nil)] [url = javascript:'<body%20onload="this.onerror%20=%20parent.onerror;%20parent.disp()"></body>']
--DOMWINDOW == 33 (0xa959eb0) [serial = 1405] [outer = (nil)] [url = javascript:'<body%20onload="this.onerror%20=%20parent.onerror;%20parent.disp(self)"></body>']
--DOMWINDOW == 32 (0xc698918) [serial = 1404] [outer = 0xa2308e0] [url = http://mochi.test:8888/tests/content/html/document/test/test_bug57600.html]
--DOMWINDOW == 31 (0xd796270) [serial = 1403] [outer = 0xbbf5108] [url = about:blank]
--DOCSHELL 0xbb68e28 == 14
--DOMWINDOW == 30 (0xbbf5140) [serial = 1402] [outer = (nil)] [url = about:blank]
--DOMWINDOW == 29 (0xd934760) [serial = 1401] [outer = 0xa2308e0] [url = http://mochi.test:8888/tests/content/html/document/test/test_bug571981.html]
--DOMWINDOW == 28 (0xc95d1a0) [serial = 1400] [outer = 0xe0b6e50] [url = data:text/html,<form><legend>]
--DOMWINDOW == 27 (0xe4b6638) [serial = 1399] [outer = 0xe0b6e50] [url = about:blank]
--DOCSHELL 0xdd36af0 == 13
--DOMWINDOW == 26 (0xe0b6e88) [serial = 1398] [outer = (nil)] [url = data:text/html,<form><legend>]
--DOMWINDOW == 25 (0xc0b5560) [serial = 1396] [outer = 0xc2dcf20] [url = http://mochi.test:8888/tests/content/html/document/test/bug369370-popup.png]
--DOCSHELL 0xc82ee20 == 12
--DOMWINDOW == 24 (0xc2dcf58) [serial = 1395] [outer = (nil)] [url = http://mochi.test:8888/tests/content/html/document/test/bug369370-popup.png]
--DOMWINDOW == 23 (0xde077d8) [serial = 1394] [outer = 0xa2308e0] [url = http://mochi.test:8888/tests/content/html/document/test/test_bug512367.html]
--DOCSHELL 0xc015660 == 11
WARNING: An error occurred while executing an async statement: 19 constraint failed: file /builds/slave/mozilla-central-linux-debug/build/toolkit/components/places/src/Helpers.cpp, line 66
48105 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | We must be on a example.org:80 - "http://example.org/tests/content/media/test/file_access_controls.html" should equal "http://example.org/tests/content/media/test/file_access_controls.html"
48106 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Get pref service
48107 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Get media pref branch
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 261
48108 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Won't load when redirected to different domain (element in document) - "error" should equal "error"
file=[xpconnect wrapped nsILocalFile @ 0xebfb910 (native @ 0xebfb798)]
48109 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Can load when redirected to different domain with allow-origin (element in document) - "loadeddata" should equal "loadeddata"
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 261
48110 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Won't load when redirected to subdomain (element in document) - "error" should equal "error"
Assertion failure: JS_HAS_OPTION(acx, JSOPTION_UNROOTED_GLOBAL), at /builds/slave/mozilla-central-linux-debug/build/js/src/xpconnect/src/xpcjsruntime.cpp:383
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80040111: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 261
NEXT ERROR 48111 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load when redirected to subdomain with allow-origin (element in document) - got "error", expected "loadeddata"
48112 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load when redirected to same domain (element in document) - got "error", expected "loadeddata"
48113 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load from same domain (element in document) - got "error", expected "loadeddata"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
48114 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Won't load from different port on same domain (element in document) - "error" should equal "error"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
NEXT ERROR 48115 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load from different port on same domain with allow-origin (element in document) - got "error", expected "loadeddata"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
48116 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Won't load cross domain (element in document) - "error" should equal "error"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
NEXT ERROR 48117 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load cross domain with allow-origin (element in document) - got "error", expected "loadeddata"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
NEXT ERROR 48118 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load from subdomain with allow-origin (element in document) - got "error", expected "loadeddata"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
48119 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Won't load from subdomain (element in document) - "error" should equal "error"
48120 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Won't load when redirected to different domain (element not in document) - "error" should equal "error"
NEXT ERROR 48121 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load when redirected to different domain with allow-origin (element not in document) - got "error", expected "loadeddata"
48122 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Won't load when redirected to subdomain (element not in document) - "error" should equal "error"
NEXT ERROR 48123 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load when redirected to subdomain with allow-origin (element not in document) - got "error", expected "loadeddata"
48124 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load when redirected to same domain (element not in document) - got "error", expected "loadeddata"
48125 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load from same domain (element not in document) - got "error", expected "loadeddata"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
48126 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Won't load from different port on same domain (element not in document) - "error" should equal "error"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
NEXT ERROR 48127 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load from different port on same domain with allow-origin (element not in document) - got "error", expected "loadeddata"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
48128 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Won't load cross domain (element not in document) - "error" should equal "error"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
NEXT ERROR 48129 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load cross domain with allow-origin (element not in document) - got "error", expected "loadeddata"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
NEXT ERROR 48130 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_access_control.html | Can load from subdomain with allow-origin (element not in document) - got "error", expected "loadeddata"
WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x804B0048: file /builds/slave/mozilla-central-linux-debug/build/content/base/src/nsCrossSiteListenerProxy.cpp, line 236
48131 INFO TEST-PASS | /tests/content/media/test/test_access_control.html | Won't load from subdomain (element not in document) - "error" should equal "error"
48132 INFO SimpleTest finished /tests/content/media/test/test_access_control.html in 6420ms
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584495
Blocks: 544875
No longer blocks: 544875
No longer blocks: 438871
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.