File corrupted which caused installation failure

RESOLVED DUPLICATE of bug 583122

Status

--
critical
RESOLVED DUPLICATE of bug 583122
9 years ago
3 years ago

People

(Reporter: lshen28, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6 NET_mmhpset GTB7.1
Build Identifier: 

Our new version of add-on (1.30) was just approved. But, seems the installation button caused the installation failure. We see the following error message:

"
Firefox could not install the file at

https://addons.mozilla.org/en-US/firefox/downloads/latest/13805/addon-13805-latest.xpi?src=addondetail

because: Invalid file hash (possible download corruption)
-261
"


To reproduce the problem, go to :
https://addons.mozilla.org/en-US/firefox/addon/13805/

And, click "Add to FireFox" button.

Reproducible: Always

Steps to Reproduce:
1. go to https://addons.mozilla.org/en-US/firefox/addon/13805/
2. click "Add to FireFox" button.
3. click install
Actual Results:  
Firefox could not install the file at

https://addons.mozilla.org/en-US/firefox/downloads/latest/13805/addon-13805-latest.xpi?src=addondetail

because: Invalid file hash (possible download corruption)
-261

Expected Results:  
Addon should be installed without any error message.
This can happen when the page is live before the file is sync'd out.  It' s a long standing problem and one which we're curing "soon"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 583122
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.