mozilla m18 core dumps on startup

VERIFIED INVALID

Status

P3
blocker
VERIFIED INVALID
19 years ago
14 years ago

People

(Reporter: keb, Assigned: asa)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
I installed the M18 binary into /usr/local/mozilla using the mozilla-installer
program, as root.  Then i switched to being a user and deleted the .mozilla/
directory.  I tried to run mozilla with each of these commands:

cd /usr/local/mozilla ; ./run-mozilla.sh

cd /usr/local/mozilla ; ./mozilla

/usr/local/mozilla/mozilla

None of them worked.  One of them gives a core dump.  This did not happen with
M17, but the M17 i ran was an i386 binary, while M18 is an i686 binary according
to its filename.  I have an AMD K6-2 350 and 64MB RAM.

Comment 1

19 years ago
You must also *start* mozilla once as root before ordinary users can run it.
There are a couple of bugs about this. A few files/chrome etc. for installed
components are created during first startup, and since normal users don't have
write-access to install directory, it will fail if these files are not present.

I recommend also starting composer once as root first, if that component is
installed. Then quit mozilla, exit root, and start as normal user.

Comment 2

19 years ago
m18 is too old and you didn't follow directions. you should be running regxpcom 
and regchrome, we have documented this. If you don't run regxpcom/regchrome you 
could run mozilla as root and force it to load its components (for chrome 
purposes).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

19 years ago
Thanks Asa, it seems to work now.  How about adding that comment to the README
in the installer...

I didn't see any instructions about regxpcom etc.  Why doesn't the installer run
them?
Target Milestone: --- → M18
verified.

they are in the release notes
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.