failure in /tests/dom/src/threads/test/test_xhr.html | Exited with code -1073741819 during test run (after GC-related JS_ASSERT)

RESOLVED DUPLICATE of bug 583598

Status

()

defect
RESOLVED DUPLICATE of bug 583598
9 years ago
7 years ago

People

(Reporter: jfkthame, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1280998917.1280999996.13985.gz

....
2729 INFO SimpleTest finished /tests/dom/src/threads/test/test_throwingOnerror.html in 1438ms
2730 INFO TEST-START | /tests/dom/src/threads/test/test_xhr.html
++DOMWINDOW == 15 (095957A0) [serial = 769] [outer = 06B5C998]
Conservative GC scanner has missed the root 0DF454E0 with tag 4294967285 on the stack. Aborting.
Assertion failure: false, at e:/builds/moz2_slave/mozilla-central-win32-debug/build/js/src/jsgc.cpp:2538
nsStringStats
 => mAllocCount:         414924
 => mReallocCount:        29918
 => mFreeCount:          378563  --  LEAKED 36361 !!!
 => mShareCount:         698265
 => mAdoptCount:          46497
 => mAdoptFreeCount:      46495  --  LEAKED 2 !!!
NEXT ERROR TEST-UNEXPECTED-FAIL | /tests/dom/src/threads/test/test_xhr.html | Exited with code -1073741819 during test run
INFO | automation.py | Application ran for: 0:09:45.188000
INFO | automation.py | Reading PID log: c:\docume~1\cltbld\locals~1\temp\tmpgw3fd7pidlog
PROCESS-CRASH | /tests/dom/src/threads/test/test_xhr.html | application crashed (minidump found)
Operating system: Windows NT
                  5.2.3790 Service Pack 2
CPU: x86
     GenuineIntel family 6 model 15 stepping 8
     1 CPU

Crash reason:  EXCEPTION_ACCESS_VIOLATION
Crash address: 0x0

Thread 0 (crashed)
 0  mozjs.dll!JS_Assert [jsutil.cpp:52d5fe9352a6 : 74 + 0x0]
    eip = 0x006d8c8a   esp = 0x0012d450   ebp = 0x0012d450   ebx = 0x00000000
    esi = 0x01662588   edi = 0x00000000   eax = 0x00000000   ecx = 0x5f02154b
    edx = 0x00541d40   efl = 0x00010216
    Found by: given as instruction pointer in context
(Reporter)

Comment 2

9 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281000678.1281001707.21804.gz

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1281001457.1281002898.27328.gz
Summary: GC-related JS_ASSERT in test_xhr.html | Exited with code -1073741819 during test run → failure in /tests/dom/src/threads/test/test_xhr.html | Exited with code -1073741819 during test run (after GC-related JS_ASSERT)
Comment hidden (Legacy TBPL/Treeherder Robot)
This is the GC rooting assertions, right?

Comment 6

9 years ago
(In reply to comment #5)
> This is the GC rooting assertions, right?

Currently the GC scans certain roots twice, once during the conservative scan of the stack and once when navigating over AutoRoots. That allows to verify that the conservative GC properly discovers roots before we remove the autoroots. But as this assert indicates at least on Windows something is wrong and some roots are missed.
Comment hidden (Legacy TBPL/Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 583598

Updated

9 years ago
Blocks: 438871
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.