Image compositing stopped working (regressed between July 30 and July 31)

RESOLVED FIXED

Status

()

Core
Canvas: 2D
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Doug Wright, Assigned: bas)

Tracking

({regression, testcase})

Trunk
x86
Windows 7
regression, testcase
Points:
---

Firefox Tracking Flags

(blocking2.0 beta4+)

Details

Attachments

(2 attachments)

Comment 1

8 years ago
Narrowed Regression window:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cc00ee24a25c&tochange=4a3e8596e8fc
Changeset 4a3e8596e8fc of Bug 576169 causes the problem
Blocks: 576169
blocking2.0: --- → ?
(Assignee)

Comment 2

8 years ago
Created attachment 463203 [details] [diff] [review]
Clear path before drawing image

The old code did a Clip(gfxRectangle), this function call destroys the current path. The new code did not in any way clear the current path, therefor certain sequences of calls could cause an incorrect path to end up being sent to fill. Clearing the path before calling fill like the other methods do indirectly fixes this.
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
Attachment #463203 - Flags: review?(vladimir)
Comment on attachment 463203 [details] [diff] [review]
Clear path before drawing image

Needs a test, if we didn't catch this any other way.
Attachment #463203 - Flags: review?(vladimir) → review+
blocking2.0: ? → beta4+
(Assignee)

Comment 4

8 years ago
Pushed http://hg.mozilla.org/mozilla-central/rev/f5834a658fe2. Leaving this open until we've added a test.
(Assignee)

Comment 5

8 years ago
I'm resolving this since it's showing as a Beta4 blocker. And the test isn't blocking Beta4.
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.