XPCJSContextStack::Push that also enters request

RESOLVED DUPLICATE of bug 868130

Status

()

Core
XPConnect
--
enhancement
RESOLVED DUPLICATE of bug 868130
8 years ago
5 years ago

People

(Reporter: Igor Bukanov, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
+++ This bug was initially created as a clone of Bug #584551 +++

XPCJSContextStack::Push is often followed by JS_BeginRequest/JSAutoREquest. This is suboptimal because Push may also call JS_SuspendRequest on the previous context meaning that the GC lock is taken twice. With changes from bug 552266 we can skip JS_SuspendRequest and call only JS_BeginRequest as the latter automatically suspends the previous active context.

Thus the idea is to have a form of Push that would also enter the request.
(Reporter)

Updated

8 years ago
Depends on: 585059
(Reporter)

Updated

6 years ago
Assignee: igor → nobody
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 868130
You need to log in before you can comment on or make changes to this bug.