nsAsyncRedirectVerifyHelper.cpp compilation failure

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: jacek, Assigned: jacek)

Tracking

Trunk
x86_64
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 463122 [details] [diff] [review]
fix v1.0

I get a compilation failure on mingw (GCC 4.5.0, I expect it to not be specific to mingw):

/home/jacek/mozilla-build/mozilla-central/netwerk/base/src/nsAsyncRedirectVerifyHelper.cpp: In member function 'void nsAsyncRedirectVerifyHelper::ExplicitCallback(nsresult)':
/home/jacek/mozilla-build/mozilla-central/netwerk/base/src/nsAsyncRedirectVerifyHelper.cpp:202:9: error: cannot pass objects of non-trivially-copyable type 'class nsCOMPtr<nsIAsyncVerifyRedirectCallback>' through '...'
/home/jacek/mozilla-build/mozilla-central/netwerk/base/src/nsAsyncRedirectVerifyHelper.cpp:202:9: error: cannot pass objects of non-trivially-copyable type 'class nsCOMPtr<nsIThread>' through '...'


The fix (attached) is to pass raw pointer instead of nsCOMPtr to LOG.
(Assignee)

Updated

8 years ago
Attachment #463122 - Attachment is patch: true
Attachment #463122 - Flags: review?(jst)
(Assignee)

Updated

8 years ago
Assignee: nobody → jacek
This is a bit of a guess, but might bug 584418 be a dupe of this?
(Assignee)

Comment 2

8 years ago
(In reply to comment #1)
> This is a bit of a guess, but might bug 584418 be a dupe of this?

It doesn't seem to be related.
Comment on attachment 463122 [details] [diff] [review]
fix v1.0

Yup, we want this. Thanks for the patch!
Attachment #463122 - Flags: review?(jst)
Attachment #463122 - Flags: review+
Attachment #463122 - Flags: approval2.0+

Updated

8 years ago
Keywords: checkin-needed
(Assignee)

Comment 4

8 years ago
Thanks for the review. Pushed to m-c:

http://hg.mozilla.org/mozilla-central/rev/efcbc31708f1
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.