NewWindow2 event does NOT go to a URL

RESOLVED FIXED

Status

Core Graveyard
Embedding: ActiveX Wrapper
P3
major
RESOLVED FIXED
18 years ago
6 years ago

People

(Reporter: Geshp, Assigned: Adam Lock)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
BuildID:    2000102920

In visual basic 6.0, the following command loaded a new form with a new 
MozillaBrowser control, but the control never went to a URL.

Private Sub brwWebBrowser_NewWindow2(ppDisp As Object, Cancel As Boolean)
Dim web As New frmBrowser
Set ppDisp = web.brwWebBrowser
web.Show
Set web = Nothing
End Sub


Reproducible: Always
Steps to Reproduce:
1. In VB6, install MozillaType1.0 controls.  Create a form using the Web 
Browser template and replace the IE control with a Mozilla control under the 
name brwWebBrowser
2. Add this sequence:
Private Sub brwWebBrowser_NewWindow2(ppDisp As Object, Cancel As Boolean)
Dim web As New frmBrowser
Set ppDisp = web.brwWebBrowser
web.Show
Set web = Nothing
End Sub
3. Browse to "www.mozilla.org/quality/help/bugzilla-help.html"
4. Click on search under step 2 on the web page

Actual Results:  A new, blank browser window pops up

Expected Results:  The window should have the target URL inside.
(Assignee)

Comment 1

18 years ago
Changing owner
Assignee: locka → adamlock

Comment 2

18 years ago
are you still seeing this reproter? 

Comment 3

18 years ago
Marking as INVALID do to lack of Response. Reopen if this is still a problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Assignee)

Comment 4

18 years ago
Reopening until I have time to check it out.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Comment 5

18 years ago
Created attachment 20034 [details] [diff] [review]
Patch to fix NewWindow2
(Assignee)

Comment 6

18 years ago
The NewWindow2 method looked pretty broken due to some dodgy casting and broken 
code. I've implemented a new IMozControlBridge interface to solve the casting 
problem and fixed up the code to function again. I'll try and get this checked 
in for next week.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 7

18 years ago
Fix is checked in now. Please wait for nightlies to carry the change and 
reopen this bug if the new behaviour hasn't fixed the problem entirely.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Component: Embedding: ActiveX Wrapper → Embedding: ActiveX Wrapper
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.