tabs behavior is messed up if the Web Console is used

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
8 years ago
4 months ago

People

(Reporter: paul, Unassigned)

Tracking

Trunk
x86
Windows 7

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(Whiteboard: [notreproduceable])

(Reporter)

Description

8 years ago
Once I used the Web Console, the tabs behavior is weird:
* URL are loaded in the previous tab, not in the current one
* middle-click to open a link in a new tab is not working (ctrl-clic or right-click -> open link in a new tab neither)
* ... more strange things

Step to reproduce:
* start firefox
* ctrl-shift-k (open the web console)
* ctrl-shift-k (close the web console)
* ctrl-t (open a new tab)
* ctrl-l, type an url, <return>

The URL is load in the previous tab.
(Reporter)

Comment 1

8 years ago
tested with 4.0b3-candidates/build2/ with an empty profile. Same behavior.
blocking2.0: --- → ?
(Reporter)

Comment 2

8 years ago
in beta2 as well.

Updated

8 years ago
Component: Tabbed Browser → Developer Tools
QA Contact: tabbed.browser → developer.tools
(Reporter)

Comment 3

8 years ago
in beta1 as well.
(Reporter)

Updated

8 years ago
Summary: tabs behavior is messed up in nightly builds if the Web Console is used → tabs behavior is messed up if the Web Console is used

Comment 4

8 years ago
very strange, I use the console all day long and have not noticed this, nor can I reproduce the problem.
(Reporter)

Comment 5

8 years ago
I've asked to a couple of people. So far, I'm the only one who has been able to reproduce this bug. I don't understand.
I am on Windows 7 too and I couldnt reproduce this error.

Comment 7

8 years ago
(In reply to comment #5)
> I've asked to a couple of people. So far, I'm the only one who has been able to
> reproduce this bug. I don't understand.

dumb question: did you try in safe mode? i know you used a clean profile.
I can reproduce this issue, every time. I believe we talked about this in yesterday's meeting, if I am not mistaken. Isn't this an issue with how the WebConsole closes and that it breaks the tabBrowser? Or was that something different?

Comment 9

8 years ago
(In reply to comment #8)
> I can reproduce this issue, every time. I believe we talked about this in
> yesterday's meeting, if I am not mistaken. Isn't this an issue with how the
> WebConsole closes and that it breaks the tabBrowser? Or was that something
> different?

Hmmm. we attach DOM nodes into the tab (the NotificationBox), then they are removed when you close the console. I don't think we do anything to alter the tabbrowser. Mihai: can you trace the code paths to make sure we never alter the tabbrowser. I have no idea how we could be.
David: I already have this issue in my TODO. Will look into it, hopefully during the weekend.

As far as I know, yes, we do not alter the tabBrowser, but maybe there's something we are clueless about, that breaks the tabBrowser. ;)
Status: NEW → ASSIGNED

Updated

8 years ago
Assignee: nobody → mihai.sucan
Seems confirmed, so blocking+ for investigation.
blocking2.0: ? → betaN+
Should I dupe Bug 584628 to this bug? I was able to reproduce this on one Windows 7 machine but not on the machine I am using right now. I was able to reproduce this in PB mode - see the error console errors in the bug.
Whiteboard: [4b3]

Updated

8 years ago
Whiteboard: [4b3] → [kd4b6]

Updated

8 years ago
Duplicate of this bug: 575813

Updated

8 years ago
Severity: normal → blocker

Comment 14

8 years ago
Reprioritizing bugs. You can filter the mail on the word TEABAGS.
Severity: blocker → major
Whiteboard: [kd4b6] → [kd4b7]
Paul (and others): can you still reproduce the bug in the latest nightly builds? I cannot reproduce this issue anymore. I presume there have been some fixes to the HUDService code, which now no longer cause problems in tabbrowser.

Comment 16

8 years ago
I have never been able to reproduce this myself.

Updated

8 years ago
Blocks: 594225

Comment 17

8 years ago
Unless someone can still reproduce this, I would like to close this bug. It's a beta blocker and it's really important to know if this is still an issue for anyone.

Updated

8 years ago
Whiteboard: [kd4b7] → [notreproduceable]
Assignee: mihai.sucan → nobody
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
No longer blocks: 594225

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.