Status

()

Bugzilla
Email Notifications
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: pn, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 5.1; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: version 3.6.1

Our team at work used an older version of Bugzilla (1.x) for tracking issues. We upgraded to 2.6.1 and since then we do not receive email notification of bugs/comments.

Have verified that the email settings are correct to the best of our knowledge (see Additional Information below)

Reproducible: Always

Steps to Reproduce:
1.Create a new bug with a few people on the CC list.
2.Make comments on the bug and submit.
3.Confirmation screen shows "Email Sent To: No One"; "Excluding: Everyone who should have gotten the email"
Actual Results:  
Bugzilla indicated that it did not attempt to send email to anybody on the cc list or the assignee. None of them received the email.

Expected Results:  
Email should have been sent to everyone on the CC list.

- Verified that the users' email settings are set to 'All Email' (Every box in the upper section is checked, every box in the lowest two rows in email preference is unchecked)
- Verified that the SMTP configuration is correct by using the password reset function (received a password reset email)

* Am marking this as a major bug because this is a significant loss of functionality for our team.
(Reporter)

Comment 1

7 years ago
Created attachment 463179 [details]
Screenshot of Email Parameters configuration page

The image contains the Email parameter setting to confirm that we have SMTP with Send Mail Now turned ON.

Comment 2

7 years ago
Your mailfrom parameter is not a valid email address. Nevertheless, that's unrelated to what you see. Make sure that:

1) email preferences are correct for the users (Preferences > Email Preferences),
2) their account has not the "no bugmail" checkbox checked (Administration > Users)
OS: Linux → All
Hardware: x86 → All
Version: unspecified → 3.6.1
(Reporter)

Comment 3

7 years ago
Thanks for the help!

Our problem was that the 'Bugmail Disabled' checkbox was checked for users by default. We probably did not move all user settings over to the new Bugzilla installation properly.

The problem has been solved. (Now I need to figure out how to make this the default for new users, but I think I'll be able to figure that out)

Thanks again!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.