oji does not build when the nspr-version of the tree is used

VERIFIED FIXED in M9

Status

Core Graveyard
Java: OJI
P3
normal
VERIFIED FIXED
19 years ago
8 years ago

People

(Reporter: Andreas Otte, Assigned: edburns)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In mozilla/modules/oji/src/Makefile.in the variable NSPR_INCLUDE_DIR is used to
get some files included from mozilla/dist/include/private. When using NSPR from
the tree this variable is not defined and this files (primpl.h,...) are not
found.

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M7

Comment 1

19 years ago
Reassigning all OJI bugs to george.drapeau@eng.sun.com

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Assignee: drapeau → edburns
Status: ASSIGNED → NEW
(Assignee)

Comment 2

19 years ago
From: Ed Burns <edburns@acm.org>
To: leaf@mozilla.org
Subject: NSPR in tree ifdef?
Reply-To: Ed Burns <edburns@acm.org>
FCC: ~/.mail/sent-mail
--text follows this line--
Hi Daniel,

I'm looking at a bug, http://bugzilla.mozilla.org/show_bug.cgi?id=5848,
that says:

In mozilla/modules/oji/src/Makefile.in the variable NSPR_INCLUDE_DIR is
used to get some files included from mozilla/dist/include/private. When
using NSPR from the tree this variable is not defined and this files
(primpl.h,...) are not found.

I understand the problem, but am not sure which solution to take.

I could modify the Makefile.in to say:

INCLUDES +=		-I$(NSPR_INCLUDE_DIR)/private \
	-I$(DEPTH)/nsprpub/pr/include/private,

but I'd rather do something like this:

ifdef MOZ_USE_TREE_NSPR
INCLUDES +=		-I$(DEPTH)/nsprpub/pr/include/private,
else
INCLUDES +=		-I$(NSPR_INCLUDE_DIR)/private
endif

Is this possible?

Thanks,

Ed
(Assignee)

Comment 3

19 years ago
*** Bug 7287 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Blocks: 5246

Comment 4

19 years ago
the problem may be with autoconf? in my autoconf.mk NSPR_INCLUDE_DIR in not
defined. i was able to make it work by changing NSPR_INCLUDE_DIR to PUBLIC --
which is defined correctly in config.mk
(Assignee)

Comment 5

19 years ago
Well, I know NSPR_INCLUDE_DIR isn't defined, but you're telling me that PUBLIC
is, and that answers my question.  I believe this gives me enough information to
fix the bug.

Thanks,

Ed
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
This bug was fixed by toshok@hungry.com on 8/9/99.  Thanks, I guess.  Though I
would have liked to have known about the change before you made it.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
This is a developer bug.  Verifing

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.