Closed Bug 584829 Opened 9 years ago Closed 9 years ago

Firefox wont start instead generating an error when the default profile is deleted.

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 278860

People

(Reporter: jeremy.pyne, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.9pre) Gecko/20100803 Ubuntu/10.04 (lucid) Namoroka/3.6.9pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)

If one manually deletes the current users active/default profile in Windows without editing the profiles.ini Firefox will refuse to start instead generating a "Firefox is already running" error message even though it is not.  The only way to fix the problem is to edit the profile.ini file and delete the missing profile.

Reproducible: Always

Steps to Reproduce:
1. Exit Firefox.
2. Delete the default profile. %USERPROFILE%\Application Data\Mozilla\Firefox\Profiles\{RANDOM}.default
2. Try to launch Firefox.
Actual Results:  
Firefox is already running error message.

Expected Results:  
Creation of a new profile and execution of the  import tool like this was a fresh install.

The startup checks should be smart enough to realize that the profile referenced in the %USERPROFILE%\Application Data\Mozilla\Firefox\profiles.ini may be missing and recreate a new one if so.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278860
You need to log in before you can comment on or make changes to this bug.