[MAC-only] Drag & Drop of address book cards to mailing list properties dialogue was broken before bug 128124

RESOLVED DUPLICATE of bug 814342

Status

defect
--
major
RESOLVED DUPLICATE of bug 814342
19 years ago
7 years ago

People

(Reporter: laurel, Unassigned)

Tracking

(Depends on 1 bug, {platform-parity, regression})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [re-filed as bug 814342, see comment 74][needs followup bug for different problem of comment 68][revisit/re-attach launchpad see also link])

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Using 2000-10-30-08 mn6 commercial branch build Mac OS 9.0
mac only, works with Win32 build and linux build

I can only drag once from address book name/card list to a mailing list window,
sometimes can't drag any.

1.  From mail window, Tasks|Address Book.
2.  Click New List, give list a name.
3.  Drag a name/card from the address book to the mail list window.
    Note:  this first address drag & drop sometimes works, sometimes doesn't
4.  Drag another name from the address book to the mail list window.
    Result:  Doesn't work.

Note:  typing names in the mail list window works and you can add several.

Actual result:  can only us Drag&Drop from address book maximum of once,
sometimes none.

Expected:  can drag&drop as many names as I want from address book to mail list.

This is a regression.
(Reporter)

Updated

19 years ago
Keywords: pp, rtm
QA Contact: esther → laurel
(Reporter)

Updated

19 years ago
Keywords: regression

Comment 1

19 years ago
Odds are low that this will make the release.  If we can identify the change 
that regressed this and come up with a very small and safe fix, we might get it. 
 It's worth a look to see if that can happen, so [rtm need info]
Whiteboard: [rtm need info]

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 2

19 years ago
cc Pinkerton since this only happened on Mac.  I'll take a look first.

Comment 3

19 years ago
Laurel, did it work if you Drag&Drop from address book to another address book?
(Reporter)

Comment 4

19 years ago
Yes, drag from AB to another AB works. Drag from AB to mail list dialog doesn't.

Comment 5

19 years ago
Any status?

Comment 6

19 years ago
No luck so far.  I found one js error but it doesn't fix it.  I'm still looking.

Comment 7

19 years ago
It looks like the ondragdrop(DropOnAddressListTree()) is never been called. I
can't figure out why since it is working fine on NT.  Need help from Drag&Drop
team. 

Comment 8

19 years ago
Alec, I saw your name in another DND bug.  Can you help Candice find out why her
handler is not being called?

Comment 9

19 years ago
PDT marking [rtm-]. There are other ways to build a mailing list, and this
doesn't crash.
Whiteboard: [rtm need info] → [rtm-]
(Reporter)

Updated

19 years ago
Keywords: relnoteRTM
Whiteboard: [rtm-] → [rtm-] relnote-user
(Reporter)

Comment 10

19 years ago
nominatge for 6.5
Keywords: relnoteRTMnsbeta1

Comment 11

19 years ago
marking nsbeta1+ and moving to mozilla0.8
Keywords: rtm
Whiteboard: [rtm-] relnote-user → relnote-user [nsbeta1+]
Target Milestone: --- → mozilla0.8

Comment 12

19 years ago
moving to mozilla0.9
Target Milestone: mozilla0.8 → mozilla0.9

Comment 13

18 years ago
marking nsbeta1- and moving to future milestone.
Keywords: nsbeta1nsbeta1-
Whiteboard: relnote-user [nsbeta1+] → relnote-user [nsbeta1+ 2/13]
Target Milestone: mozilla0.9 → Future
what i see in the 2/12 build is that i can drag as many addresses as I want into 
a mail compose widget as long as I don't drop on the text field. If i drop 
"between" the text areas for typing the address or in an area of the addressing 
widget that is empty, it works just dandy. It seems that the text field is 
accepting the drop, but not correctly processing it.

Comment 15

18 years ago
Mike,  Dragging into compose window is working.  Dragging into a Mailing list 
dialog is broken here.  You should go to address book window and click on New 
List.
ok, now that i know what i'm doing ;), I tried this and it works perfectly for
me. is there still a bug here? 2/12/01 mac opt bits.

Comment 17

18 years ago
I tried on my mozilla debug build, it doesn't work.  I'll try again after my 
tree compiled.   Laurel,  can you try it on your machine?
tried this again with my 2/13/01 afternoon moz debug build and it worked just
dandy. i must be doing something wrong. ;)

chuang, can you drag _anything_ on your mac? maybe your mac is wedged somehow
and dragndrop is just broken. I've seen that state before.

Comment 19

18 years ago
Well,  I can't drag over compose window, mailing list dialog and mail window.  
But I can drag into bookmark window on my Mac.  This is using 2-14 commercial 
build.  I was able to drag into compose window but not mailing list dialog 2 
month ago.   I think we need QA to verify if it's working or not.

Comment 20

18 years ago
Isn't this one a dup of bug 45064 ?

Comment 21

18 years ago
This *doesn't* work for me on the very latest build on winNT (2001-03-19).

Comment 22

18 years ago
*** Bug 72790 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

18 years ago
QA Contact: laurel → fenella
(Reporter)

Updated

18 years ago
QA Contact: fenella → nbaca

Comment 23

18 years ago
reassigning to racham.
Assignee: chuang → racham
Status: ASSIGNED → NEW
Whiteboard: relnote-user [nsbeta1+ 2/13] → relnote-user

Comment 24

18 years ago
Branch build 2001-10-22: Mac 9.1
It appears to be working now. Laurel, is it working for you?

Updated

18 years ago
Blocks: 118769

Comment 25

18 years ago
I'm using build ID 2002012408 with MacOS 8.6 and the problem is still here.
I've only been using Mozilla since last spring, and never noticed this problem
before now, which seems odd considering the previous posts to this bug.
I went back to some older builds I still have on my HD, and they won't work
properly either, although I'm sure at one point this was working.

Michael

Comment 26

17 years ago
using all recent nightly builds this happens.  I could drag all the names i
wanted to the mailing list save one.  this one name refuses to be transfered. 
These are all imported from outlook express.  I wonder if this has anything to
do with anything.  I also cannot create new cards because the input fields will
not allow me to place my cursor within them or type in the, though this is
another bug.  Has anyone else experienced this.  I will start a clean profile
and see if i can create cards in it.

Comment 27

17 years ago
This is totally broken now. I think it might be due to the fixes for list imports.
When one opens the list editor on the 2002030508 win2k release, the box is
MODAL!!!! If you click on the main address book to get an address, it beeps.

So mailing lists are impossible to create now.

Comment 28

17 years ago
Nominating for MachV, this is a very visible regression that basically breaks a
major feature.  The text in the window even tells you to drag addresses into it,
but that is impossible. Shipping with this broken will be sufficient reason for
mailing list users to shun the entire product.  On Mac it is worse, because it
is application-modal (not just window-modal), so you are prevented from using
the entire browser.  On MacOS X, you can't even *see* the addresses, because the
modal dialog pane drops down on top of them.  That means you have to type the
addresses from memory, or close it until you can get back in with an external
list.  We should consider allowing copy/paste, and prefilling the new list with
the selection in the future, but can't we fix this basic funcationality for MachV?
Keywords: nsbeta1

Comment 29

17 years ago
Isn't it as easy as making the box non-modal again? I have been complaining
about this since they ruined it, and to NO avail.

I pointed out in the "can't import mailing list" bug (62084) exactly when this
happened.

In that bug I got several responses that claimed that it was easy to edit lists,
but it is in fact impossible. 

At the time the box went modal, there were still a bunch of bugs concerning the
editing box. It would not scroll properly and also put in blank lines.

In my opinion, this is a blocker for a release.

Comment 30

17 years ago
marking nsbeta1- per mail triage.  
Keywords: nsbeta1nsbeta1-

Comment 31

17 years ago
Adding helpwanted keyword.  I suspect that Netscape will never have any
motivation to fix this because we have an easy way to create server-side mailing
lists, so nobody here depends on this feature to work.
Keywords: helpwanted

Comment 32

17 years ago
Sol Spitzer@Netscape is dead set against making the address list window
non-modal. In that case, the solution is to add a second pane to the modal
window that has the address book list available for dragging into the list pane. 

In this way, Sol's objection (that people could go and muck things up in the
main window while the address list editor was open) and mine (that you HAVE to
see and access both the list and the address book at once) would both be satisfied.

I also feel that this is essential to the 1.0 release. People rely upon mailing
lists, and they must be createable and editable in a nice manner.

Comment 33

17 years ago
I have thsi bug on Win2k : I create a list, and CAN't drag / drop addresses.

This is a blocker for me !!!!!
Still unresolved??? Any targets for this??? It reduce sens of Mozilla 1.0 if it
doeasnt gives ppl effective way to organize mailbook. Any targets for this???

Comment 35

17 years ago
See also bug 161901.

Comment 36

17 years ago
Coming back to my comment #32, it is not clear what evil will occur if the "add
names" dialog is non-modal. And is it the lesser of the evils?

In the meanwhile, the users suffer from unworkable mailing lists.

I do note that before the dialog was made modal, it had severe problems. The
scrolling didnt work properly, and there would often be blank places in the list.

I propose turning off the modal switch until a better solution is found.
mass re-assign.
Assignee: racham → sspitzer
confirmed for MacOS X as well
OS: Mac System 9.x → MacOS X

Comment 39

16 years ago
This bug needs to have a higher priority. Mailing lists just plain do not work.
I can drag names to the list until I am blue in the face, but then they
disappear or are replaced by the user's name (as opposed to his e-mail).

Why is there no one working on it? It needs to be fixed for 1.5b!!

This all used to work wonderfully.

Comment 40

16 years ago
I am new to Bugzilla so please pardon any gaffes I make.

I'm having this problem with Mozilla 1.21 which I've been using pretty much ever
since it came out on a variety of machines mostly with Win98. At different times
I've had problems with the address book drag and drop, and other times I've had
problems with Mozilla locking up, or refusing to load at all, or refusing to
start mail or the AB after the browser is running. I've come to the conclusion
that this is no coincidence, that the AB problems are at the root of all of
this. Every time I run into the problem it seems to get more severe. 

I recently uninstalled Mozilla, deleted old profiles (saving the data), and made
a clean install. I didn't import the old AB for a while to make sure everything
was stable; I just added names to the clean AB as needed. After a few weeks of
stable operation I imported the AB with lists and everything was fine; I even
sent out a message to various lists. Then tonight I tried to drag/drop a new
name into a mailing list. After a few attempts Mozilla locked up, and though I
can start up the browser I can't start up Mail from the Start menu, a shortcut
on the desktop, or the button on the bottom of the browser window. Ditto with
the AB button. So I guess I will try a clean reinstall again. This is a Win98
box, the one where my lists are the largest and the most dynamic and the one
with the most problems.

I was hoping that moving up to 1.4 or 1.5b or Thunderbird would fix things, but
judging from the many, many bug reports I've seen about D&D in the AB, this
problem has been around for a long time on all platforms and there has been no
progress fixing it. Most of the bugs get reported as duplicates and most of the
others get closed with the "works for me" treatment.

Obviously this is a subtle and/or intermittent bug and I'm frustrated enough
that I'm ready to do some methodical debugging, but I'm not sure how to proceed.
If anyone can give me some suggestions, I'd appreciate it.

Comment 41

16 years ago
Bug 97854 looks related, but I'm note completely sure this is a dupe. Anyone?
Product: Browser → Seamonkey
This bug morphed, unacceptably in my view, starting at comment 27.  That problem 
is/was entirely different from the (Mac-only) problem originally reported here.  

The "new" problem, brought on by the "fix" for bug 128124, is that the mailing 
list dialog is modal (and is present on all platforms); the actual bug for 
fixing that problem is bug 135126 (and see also bug 115904).  Everyone who is 
watching this bug thinking it's about that issue is advised to watch 135126 
instead.

Since the modal dialog effectively prevents anyone from testing if the original 
bug still exists, I'll be adding a dependency.
Priority: P3 → --

Updated

14 years ago
Depends on: 135126

Updated

14 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
Component: Address Book → MailNews: Address Book
Product: Mozilla Application Suite → Core
QA Contact: nbaca → addressbook

Comment 43

12 years ago
I am reporting that this is an issue in Thunderbird 2.0.0.4 and a very big issue for our enterprise here.  

Comment 44

12 years ago
(In reply to comment #43)
> I am reporting that this is an issue in Thunderbird 2.0.0.4 and a very big
> issue for our enterprise here.  
> 

Sorry - this is not Mac-based, it's Windows.  And apparently the solution is to hold CTRL while dragging.  

Mea culpa.

Comment 45

12 years ago
this should be fixed in 2.0.0.5, iirc - you can try a 2.0.0.5-pre build here:

ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8

Comment 46

12 years ago
Still cannot drag from PAB to a list in 2.0.0.6 in WinXP.  Have tried dragging, control/drag, shift/drag, and alt/drag.  Have restarted TB, have rebooted, and have tried safe mode.

This is a major annoyance causing duplicate card creation in lieu of simply dragging.  And a dupe card causes a dupe entry in the PAB.
(In reply to comment #46)
> Still cannot drag from PAB to a list in 2.0.0.6 in WinXP.  

Miles, both click and shift+click drag WFM in windows XP.  (ctrl is no longer needed 

Does AB entry you drag have both an email address and display name? (bug 248786)
Is mailing list in the same address book as the card?
Are you dragging more than one address at a time?
Are there any special characters in the name or email address?
Do you see any errors in the console?  (tools>error console)

Comment 48

12 years ago
Click and shift+click usually are not working.  Sometimes I can drag from the PAB or a list under the PAB to another AB, but that's a move, not a copy. Then can drag it back and it's sometimes recognized as a copy.

Yes, have both email address & display name
The mailing list may be in the PAB or it may be in another AB.
Only dragging one address at a time.
No special characters
There were multitudes of entries in the error console, so I've deleted all and will try again tomorrow and will post results here.
MAC users - let's clarify, is an open mailing list window on MAC just modal to AB?  Or is it modal to the entire application as noted in bug 28?  


Miles, just realized your problem might not be related to this bug.  If your problem is not about dragging to an open mailing list _window_ then you need to file a new bug. 

Notes:
- thunderbird relative of this bug is bug 282841
- Bug 381276 enabled click drag without needing ctrl starting version 2.0.0.5)

Comment 50

12 years ago
Is my problem related or different?  Using TB2.0.0.9, WinXP,SP2, cannot always drag an entry from the list of address books (and mailing lists) to another address book or mailing list.  And this is still driving me buggy.

Have discovered that if an entry does not contain an email address, it probably will not copy, although it may.  For instance today attempted to drag XXX entry from the PAB to a mailing list below it.  When it did not contain an email address it would not drag.  If an email address were added, it would drag.   The same occurred when dragging from the PAB to another address book.

It must be said that this is not as it occurs 100% of the time, but mostly.  Have also found that frequently if drag from PAB to another AB, it is moved, not copied.  However, if Control/Drag it is copied.
Can anyone reproduce a hang that I was able to some times cause during testing?
Bug 391839 – click address book hangs thunderbird high CPU

I haven't tested this lately

Comment 52

11 years ago
Have found that when addresses refuse to drag, restarting TB fixes it.  But this refusal to drag is without warning and the average user would simply give up using Mozilla's AB!

Updated

11 years ago
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3.0a1?

Comment 53

11 years ago
This bug shows as being MAC only, but it also pertains to WinXP Home,sp2.  How can that be changed, or need I add another bug?

Updated

11 years ago
Flags: blocking-thunderbird3?
Flags: blocking-thunderbird3.0a1?
(Assignee)

Updated

11 years ago
Product: Core → MailNews Core
Duplicate of this bug: 445423
Target Milestone: Future → ---
Miles in comment #50:
> Is my problem related or different?  Using TB2.0.0.9, WinXP,SP2, cannot always
> drag an entry from the list of address books (and mailing lists) to another
> address book or mailing list.  And this is still driving me buggy.
> 
> Have discovered that if an entry does not contain an email address, it probably
> will not copy, although it may. 

this issue is bug 248786

(In reply to comment #7)
> It looks like the ondragdrop(DropOnAddressListTree()) is never been called. I
> can't figure out why since it is working fine on NT.  Need help from Drag&Drop
> team.

can someone determine if that still happens?


(In reply to comment #42)
> Since the modal dialog effectively prevents anyone from testing if the original 
> bug still exists, I'll be adding a dependency.

as a result of the blocker, as a practical matter, I don't see much value to keeping this open, because prior to comment 27 there is no testcase, let alone a reduced testcase, and no clear steps that others can replicate. And no one from that era (except James I think) seems interested enough to speak up.

Unless we want this to be the cesspool for all drag and drop bugs with no testcases or poorly formed reports - in which case the currently vague summary needs improvement. But given this bug's ragged long history I'd sooner pick a newer, shorter, more clearly worded bug.
Keywords: helpwanted
Whiteboard: relnote-user

Comment 56

9 years ago
The address book functionality is STILL much worse than on Netscape. Now, to add names to a list, you have to know the name and start typing it. Previously, the list box was in a separate window, and you could drag names from the main list. It would seem to me to be easy to restore this functionality.

In addition, the mailing lists are not exported when you export the address book!
Changed OS and platform because here there are dupes on Windows and Linux
OS: Mac OS X → All
Hardware: PowerPC → All
Duplicate of this bug: 343304
Duplicate of this bug: 595084

Comment 60

9 years ago
WinXP, TB 3.1.6, this 10-year old bug persists.  Believe it was OK a couple of versions back, but then regressed. Cannot copy or move from PAB to a list or another AB, or back from another AB to the PAB or a list under the PAB.  Have tried dragging, cntrl/drag, cntrl/shift/drag, etc.

What does it take to have this bug assigned?

Comment 61

8 years ago
Evidently the upgrade to TB3.1.7 somehow partially cleaned it up.  Today using the full screen AB I could copy (cntrl/drag) several cards from the PAB to a list under the PAB and to other AB's.

However, out of about 12, 2 will not copy or move (cntrl/drag or drag) from the PAB to a list under the PAB, but they did copy to other AB's.  Tried several times including rebooting, but no change for those 2.   One has a valid email address & the other has a dummy email address -- xxxx@xxx.com.  There 
may be may more of these difficulties, but I ran out of time before checking all addresses.

Could this be caused by a bug in those cards?  I'll try making a new duplicate card in the PAB & see if that works, unless someone has another suggestion.

Comment 62

8 years ago
Actually, on a Mac, it is impossible to drag and drop because the list is attached to the address book header. This makes lots of things hard. The list should be in its own window. Forget about the Mac look and feel guidelines. It kills the functionality.

Comment 63

8 years ago
In WinXP copied the 2 address cards that would not copy earlier today and one would now copy from PAB to a PAB list and the other would not.  Both will copy to another AB.  Also added a new card to the PAB and it will copy to another AB, but not to a list under PAB.  Apparently drag/copy remains broken.

Comment 64

8 years ago
I can confirm this as still being an issue in the latest stable version (3.1.7) as well as Mozilla Daily's Thunderbird "shredder" 3.1.9~hg20110126r5943+nobinonly-0ubuntu3~umd3~maverick.

Bug has been reported downstream (Ubuntu):
https://bugs.launchpad.net/thunderbird/+bug/711314
(In reply to comment #64)
> I can confirm this as still being an issue in the latest stable version (3.1.7)
> as well as Mozilla Daily's Thunderbird "shredder"
> 3.1.9~hg20110126r5943+nobinonly-0ubuntu3~umd3~maverick.

Thanks, but there's no need to confirm a bug as still being open if it is already marked as open. The only time you might need to do this is if someone explicitly asks (which certainly isn't the case here).

Comment 66

8 years ago
This was working for a short while through a few minor update versions.  Apparently version 3.1.7 or shortly prior again causes it to fail. Now on 3.1.9 without being corrected.  It will copy from the PAB to another AB, but not to a list under PAB or a list under another AB.

Believe it should operate with control/drag, but can't find anything on contacts in help. This has been going on for years and I've threatened before and now will install another email program that will allow control of contacts, which is sorely needed prior to my next trip out of country next month.  Perhaps I'll simply use my Google account and after updating, simply delete TB - sorry to leave you, but you offer no choice.

Comment 67

8 years ago
Thanks Komputes.  I appreciate knowing what's going on.

Comment 68

7 years ago
STILL Doesn't work 2/18/2012   Version 10.0.2

Go to address book.
Open one of the address lists, new window "Mailing List" with List name.
There is ONE open line at the bottom waiting for the next entry.
Drag and drop an email address from another source such as an email message content in one of your email folders.
The drag and drop email occupies the open line on the Mailing List as expected.
Drag and drop another to add to the list and there is no open line to drop it in.

You have to click on the Mailing list and manually scroll down to open a new empty line.

Comment 69

7 years ago
But on a Mac, it does NOT open in a separate window! So you cannot drag and drop from your main address book.

TB needs to override the Mac "style" guidelines and use a separate window.

Updated

7 years ago
Summary: Drag&Drop address book name to mailing list broken. → Drag&Drop address book cards to mailing list broken

Comment 70

7 years ago
Wow, what a confusion here!

(In reply to Mike Cowperthwaite from comment #42)
> This bug morphed, unacceptably in my view, starting at comment 27.  That
> problem is/was entirely different from the (Mac-only) problem originally
> reported here.  

+1 

> The "new" problem, brought on by the "fix" for bug 128124, is that the
> mailing list dialog is modal (and is present on all platforms); the actual bug
> for fixing that problem is bug 135126 (and see also bug 115904).  
> Since the modal dialog effectively prevents anyone from testing if the
> original bug still exists, I'll be adding a dependency.

+1

(In reply to Wayne Mery (:wsmwk) from comment #55)
> as a result of the blocker, as a practical matter, I don't see much value to
> keeping this open, because prior to comment 27 there is no testcase, let
> alone a reduced testcase, and no clear steps that others can replicate.
> ...
> Unless we want this to be the cesspool for all drag and drop bugs with no
> testcases or poorly formed reports - in which case the currently vague
> summary needs improvement. But given this bug's ragged long history I'd
> sooner pick a newer, shorter, more clearly worded bug.

+1

I see two ways of clearing this up:

1) Morph this bug back into a MAC-only bug to be revisited after fix for bug 135126, with a crystal clear summary, and an entry in Whiteboard pointing to an authoritative comment explaining the matter

Or

2) Shut this bug down and create a new MAC-only bug to be revisited after fix for bug 135126, with a crystal clear summary, and description pointing to those other bugs like bug 135126

Before doing that, I'd like two pieces of information (A+B):

A)

(In reply to James Rome from comment #69)
> But on a Mac, it does NOT open in a separate window! So you cannot drag and
> drop from your main address book.
> TB needs to override the Mac "style" guidelines and use a separate window.

As a windows user, I'm confused bc comment 0 suggests the presence of a Mailing List *window* on MAC, whereas comment 69 denies the same.

James, can you "add an attachment" to this bug, with a screenshot showing the current design of Mailing List Properties dialog on MAC?

Does the window/non-window design of MAC play any role for this bug (I think not)?

B) Do we have a bug for comment 68 (which is clearly different from this bug, but perhaps it is blocking bug 135126)?

(In reply to Ann-Marie from comment #68)
> Go to address book.
> Open one of the address lists, new window "Mailing List" with List name.
> There is ONE open line at the bottom waiting for the next entry.
> Drag and drop an email address from another source such as an email message
> content in one of your email folders.
> The drag and drop email occupies the open line on the Mailing List as
> expected.
> Drag and drop another to add to the list and there is no open line to drop
> it in.
> 
> You have to click on the Mailing list and manually scroll down to open a new
> empty line.
Flags: needinfo?(jamesrome)

Comment 71

7 years ago
Adding more prominent pointer to the Thunderbird equivalent of this bug (keeping which might be helpful to avoid duplicates in TB product).
See Also: → 282841

Comment 72

7 years ago
(In reply to Thomas D. from comment #71)
> Adding more prominent pointer to the Thunderbird equivalent of this bug
> (keeping which might be helpful to avoid duplicates in TB product).

I fell prey to the confusion myself. TB bug 282841 is the equivalent of Mailnews Core bug 135126, so it's not related to the original MAC problem of this bug, and the see-also pointer will just undermine our efforts to isolate the MAC problem in this bug as proposed in comment 70.
See Also: 282841

Comment 73

7 years ago
Note that the list window covers the underlying names a la the Mac style guide, which should be ignored in this case.
Flags: needinfo?(jamesrome)

Updated

7 years ago
Blocks: 814342

Updated

7 years ago
No longer blocks: 814342

Comment 74

7 years ago
As announced and explained in comment 70, I will close this bug because it has lost focus of the original MAC-only problem and has become too messy to maintain.

* The original MAC-only problem of this bug has been re-filed as bug 814342. That problem was observed *before* bug 128124 made the list properties dialogue modal on all OS, so it cannot currently be tested and needs to be revisited after fix for bug 135126.

* Bug 135126 (and its TB-twin bug 282841 currently kept open as a duplicate collector) covers the current problem on *all* OS that it is generally not possible to drag & drop cards into the List properties dialogue because the dialogue window is modal.

Todo:
- check if different problem of Comment 68 is covered by its own bug (that's a problem of dragging *text* into the list properties dialogue, and it doesn't create new lines for subsequent addresses as expected)
- revisit & sort out duplicates of this bug and move them to the appropriate current bugs. Due to the morph-mess in this bug, I'd expect some of them to be dupes of bug 135126 rather than bug 814342.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
OS: All → Mac OS X
Resolution: --- → DUPLICATE
Summary: Drag&Drop address book cards to mailing list broken → [MAC-only] Drag & Drop of address book cards to mailing list properties dialogue broken
Whiteboard: [re-filed as bug 814342, see comment 74][needs followup bug for different problem of comment 68][needs revisiting and moving of unfit duplicates]
Duplicate of bug: 814342

Updated

7 years ago
Summary: [MAC-only] Drag & Drop of address book cards to mailing list properties dialogue broken → [MAC-only] Drag & Drop of address book cards to mailing list properties dialogue was broken before bug 128124

Comment 75

7 years ago
I purged the unfit dupes of this bug and re-duped them to where they belong.
Whiteboard: [re-filed as bug 814342, see comment 74][needs followup bug for different problem of comment 68][needs revisiting and moving of unfit duplicates] → [re-filed as bug 814342, see comment 74][needs followup bug for different problem of comment 68]

Comment 76

7 years ago
Somebody should check to which of the current bugs the following link belongs, currently found in see-also of this bug:

https://launchpad.net/bugs/711314
Whiteboard: [re-filed as bug 814342, see comment 74][needs followup bug for different problem of comment 68] → [re-filed as bug 814342, see comment 74][needs followup bug for different problem of comment 68][revisit/re-attach launchpad see also link]
You need to log in before you can comment on or make changes to this bug.