Status

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: jsocol, Assigned: jsocol)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Now that 2.2 is out, I think we can close out the old forums... permanently. <laugh type="evil"/>

I have a patch that just deletes all the user-facing forum scripts from SVN. I'm doing some basic regression testing now.
(Assignee)

Comment 1

8 years ago
Created attachment 463299 [details] [diff] [review]
a blunt hammer to the tiki forums

People keep posting in the old forums, having gotten there by some dark magic. This utterly prevents that.

It prevents it by *removing* from SVN the tiki files that provide all, or most, the user-facing forum features. (Note that patch will remove the contents but not the files. SVN will remove the files.)

I've done some spot-testing for regressions on the KB, anything that touches tiki_comments, basically. So far, it looks OK. There wasn't much in Litmus and there are no automated tests I could run. :( Hopefully selenium will cover some of it.
Attachment #463299 - Flags: review?(paulc)
Comment on attachment 463299 [details] [diff] [review]
a blunt hammer to the tiki forums

WFM.

Played with user account, watches, page renames, page edits and a few other things. Didn't see anything in the code that would cause breakage, either.

I see there is also tiki-admin_forums.php, but that shouldn't be a problem to have around.

Hopefully all the testing we will do (QA++) is enough to keep these files outta svn for good ;)
Attachment #463299 - Flags: review?(paulc) → review+

Comment 3

8 years ago
Um, can this wait for a couple months?

Because we can't migrate the FxHome forum and keep links working, we decided to keep the original forum, lock those threads and redirect people with a message "please use this new link".  New threads will of course be in kitsune.

I want to give about 2 months or so for everyone who could conceivably be looking for specific threads in the old forums to read that message.
(Assignee)

Comment 4

8 years ago
(In reply to comment #3)
> Because we can't migrate the FxHome forum and keep links working, we decided to
> keep the original forum, lock those threads and redirect people with a message
> "please use this new link".  New threads will of course be in kitsune.

You can lock the threads easily enough, but can you lock the forums themselves? I did this now because we've seen people trickle in to the old forums (even the old discussion forums) well after we'd moved over to the new ones.

Comment 5

8 years ago
I can remove all permissions to create posts.  (Doing so now...)

Comment 6

8 years ago
I retained the right for Admins to do anything but no other group has permissions on any forum except the iPhone forum.
(Assignee)

Comment 7

8 years ago
That should help. This patch can wait, then, as it's not likely to bitrot.
(Assignee)

Comment 8

8 years ago
It's been about 2 months. Can we go ahead and clear these files out?

Comment 9

8 years ago
Go go go!
(Assignee)

Comment 10

8 years ago
So, technically we never deleted the files, but you can't get to them anymore. Long live Kitsune.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.