Past Events link results in page 404 not found

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: aakashd, Assigned: craigcook)

Tracking

unspecified
x86
Mac OS X

Details

(Reporter)

Description

8 years ago
Steps to Reproduce:
1. Go to QMO Event pages
2. Click on "Past Events"

Actual Results:
404 page error

Expected Results: 
We should be able to see past events
(Reporter)

Updated

8 years ago
Severity: normal → major
(Reporter)

Updated

8 years ago
Target Milestone: --- → 2.5
(Assignee)

Comment 1

8 years ago
This seems to be a problem with the "Pretty URLs" in The Events Calendar plugin, which just rewrites URLs so they look better than a query string. Turning off pretty URLs makes past events reachable again so we know the data is there, it's just the rewritten URL that's failing.

But once again, it works on stage and not in production, so the solution lies in finding where the two servers differ. I suspect this might be related to bug 583105 (can't create events). 

The quick fix is turning off pretty URLs, and maybe we can turn them back on if/when we sort out the real problem.
Assignee: nobody → craigcook.bugz
(Reporter)

Comment 2

8 years ago
Turning off pretty URL is a fine option to me if this doesn't get resolved in bug 583105
(Assignee)

Comment 3

8 years ago
I'm not sure exactly what fixed it, but I suspect it might have been flushing the cache. In any case, it's working now in prod.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.