Add .valid() filter to Addon.featured()

VERIFIED FIXED in 5.11.8

Status

VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: pratibha, Assigned: jbalogh)

Tracking

unspecified
5.11.8
x86
Windows 7

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Steps:
-----

- Load https://next.addons.mozilla.org/en-US/firefox/addon/2207/

Result: Error 404 page not found
Well, search (https://next.addons.mozilla.org/en-US/firefox/search/?q=coolpreviews+&cat=all&lver=any&pid=1&sort=&pp=20&lup=&advanced=on) isn't finding it either; from where did you find a link to it?

Add-on IDs are not guaranteed to be consistent across preview+next vs. prod.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Well, search
> (https://next.addons.mozilla.org/en-US/firefox/search/?q=coolpreviews+&cat=all&lver=any&pid=1&sort=&pp=20&lup=&advanced=on)
> isn't finding it either; from where did you find a link to it?
> 
> Add-on IDs are not guaranteed to be consistent across preview+next vs. prod.

from view all featured link:
https://next.addons.mozilla.org/en-US/firefox/featured
(Reporter)

Comment 3

8 years ago
Created attachment 463483 [details]
snapshot shows the coolpreviews button state
(Assignee)

Updated

8 years ago
Assignee: nobody → jbalogh
Summary: page not found for add-on coolpreviews → Add .valid() filter to Addon.featured()
Target Milestone: --- → 5.11.8
Status: NEW → RESOLVED
Last Resolved: 8 years ago
OS: Mac OS X → Windows 7
Resolution: --- → DUPLICATE
Duplicate of bug: 585072
(Assignee)

Comment 5

8 years ago
http://github.com/jbalogh/zamboni/commit/e62eaf0
Resolution: DUPLICATE → FIXED
Verified FIXED on the homepage and https://next.addons.mozilla.org/en-US/firefox/featured; I asked Jeff to null out current_version for https://next.addons.mozilla.org/en-US/firefox/addon/6937/, and it correctly was removed from the /featured pages.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.