The function Bugzilla::Attachment->create requires a description argument, and that argument was not set.

RESOLVED DUPLICATE of bug 653404

Status

()

Bugzilla
Attachments & Requests
--
minor
RESOLVED DUPLICATE of bug 653404
8 years ago
7 years ago

People

(Reporter: timeless, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
Steps:
1. load https://bugzilla.mozilla.org/attachment.cgi?bugid=577917&action=enter
2. select file
3. enter description "using #ifdef DEBUG"
4. check patch
5. mark review +
6. check box to oboslete  456744: patch
7. click submit
8. get error message (internal server error?) (not the one above)
9. click back in web browser
10. at this point the file field is empty :(
11. ignore 10
12. click submit again

actual results:

Bugzilla has suffered an internal error. Please save this page and send it to bugzilla-admin@mozilla.org with details of what you were doing at the time this message appeared.

URL: https://bugzilla.mozilla.org/attachment.cgi

The function Bugzilla::Attachment->create requires a description argument, and that argument was not set.

expected results:
1. a helpful error message at the top of the page indicating that i didn't specify a file to attach
2. the entire create attachment page with everything i've filled out should be reproduced so that i can simply reselect the file and click submit

Comment 1

8 years ago
I don't know how you managed to trigger this error (JS on/off?), nor which internal error you got, but I cannot reproduce. If the file field is empty, I get "You did not specify a file to attach".
Severity: critical → minor
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Version: 3.4.3 → 3.6.2
(Reporter)

Comment 2

8 years ago
I'm using safari:
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-us) AppleWebKit/533.17.8 (KHTML, like Gecko) Version/5.0.1 Safari/533.17.8

JavaScript is enabled (including the completion stuff from Bugzilla).
(Reporter)

Comment 3

8 years ago
I just hit this again with bug 585006

The initial message is:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, bugzilla-admin@mozilla.org and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Bugzilla@Mozilla – Missing Parameter

Bugzilla has suffered an internal error. Please save this page and send it to bugzilla-admin@mozilla.org with details of what you were doing at the time this message appeared.

URL: https://bugzilla.mozilla.org/attachment.cgi

The function Bugzilla::Attachment->create requires a description argument, and that argument was not set.

Could someone from IT please find out what the ISE i've hit was?
Assignee: attach-and-request → server-ops
Severity: minor → critical
Status: RESOLVED → REOPENED
Component: Attachments & Requests → Server Operations
Product: Bugzilla → mozilla.org
QA Contact: default-qa → mrz
Resolution: WORKSFORME → ---
Version: 3.6.2 → other
(In reply to comment #3)
> Could someone from IT please find out what the ISE i've hit was?

You didn't hit an ISE.  Bugzilla doesn't trap ISEs, so you would have gotten the usual bland page from apache if that's what you'd gotten, instead of the pretty error from Bugzilla.
Assignee: server-ops → nobody
Component: Server Operations → Bugzilla: Other b.m.o Issues
QA Contact: mrz → other-bmo-issues
(Reporter)

Comment 5

8 years ago
justdave: no, I got two errors, and they're both significant. the first one was an ISE:


Internal Server Error
The server encountered an internal error or misconfiguration and was unable to
complete your request.
Please contact the server administrator, bugzilla-admin@mozilla.org and inform
them of the time the error occurred, and anything you might have done that may
have caused the error.


Only when I try to resubmit do I get the normal bugzilla "pretty" error.

Anyway, can you see if there's anything in the log for the requests I made for those bugs?
ok, here we go:

w.x.y.z - - [06/Aug/2010:05:42:11 -0700] "POST /attachment.cgi HTTP/1.1" 500 546 "https://bugzilla.mozilla.org/attachment.cgi?bugid=585008&action=enter" "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-us) AppleWebKit/533.17.8 (KHTML, like Gecko) Version/5.0.1 Safari/533.17.8"

Not a damn thing in the error log at that timestamp :(

There's one of these:
[Fri Aug 06 05:43:01 2010] [error] Software caused connection abort at /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Template.pm line 163.\n

a minute before and a minute after.

Comment 7

8 years ago
LpSolit: I've seen this too, and it does have something to do with leaving the File argument blank. It might only happen with certain browsers. I recall looking at the code and seeing the problem, but I don't recall it offhand now. Something to do with how arguments get passed to create().

Comment 8

8 years ago
BTW, this probably won't be reproducible on trunk, because of the attach_text changes. You'll have to try the 4.0 branch, which I think is the only one affected.
(In reply to comment #8)
> BTW, this probably won't be reproducible on trunk, because of the attach_text
> changes. You'll have to try the 4.0 branch, which I think is the only one
> affected.

and 3.6, I assume?

Comment 10

8 years ago
(In reply to comment #9)
> and 3.6, I assume?

  Maybe. It might be related to the backport of the new page, though.
Assignee: nobody → attach-and-request
Component: Bugzilla: Other b.m.o Issues → Attachments & Requests
OS: Mac OS X → All
Product: mozilla.org → Bugzilla
QA Contact: other-bmo-issues → default-qa
Hardware: x86 → All
Target Milestone: --- → Bugzilla 4.0
Version: other → 3.7.3
Got another report that this seems to have come from not filling in the File: field.

Comment 12

8 years ago
Leaving the File field empty is definitely not what I call a *critical* bug.
Severity: critical → minor

Comment 13

7 years ago
I still cannot reproduce this bug, but it may be related to bug 653404 (the web server doesn't have permissions to read the file).

Comment 14

7 years ago
I'm pretty sure this is the same root cause, and my patch there will fix this issue anyway.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago7 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 4.0 → ---
Duplicate of bug: 653404
You need to log in before you can comment on or make changes to this bug.