Closed Bug 585098 Opened 12 years ago Closed 12 years ago

Port branch name refactoring for talos sendchanges to 0.7.10/default masters (releases and tigers)

Categories

(Release Engineering :: General, defect)

x86
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: armenzg, Assigned: catlee)

References

Details

(Whiteboard: [regression])

Attachments

(3 files)

This is a fallout from bug 568568 where some refactoring happened on the talos branch name on the sendchanges.

This also has to be ported to default so it works for releases.

I have attached what looks to be change needed (not tested just tried to apply attachment 462435 [details] [diff] [review]).

catlee is this something you could take on since you have this code more fresh than I?
This is something that is affecting http://talos-master.mozilla.org:8010

Is there a reason the tiger slaves live in their own masters rather than with the rest of platforms? (even if they are not Rev3 machines)
Severity: normal → major
Priority: P3 → --
Summary: Fix branch name for talos release sendchanges → Port branch name refactoring for talos sendchanges to 0.7.10/default masters (releases and tigers)
Whiteboard: [regression]
All that needs to happen is to adjust the branch names for default.

I don't know about porting the rest of the code...I guess it's worth having the builder names line up.
Assignee: nobody → catlee
Yeah I just meant the branch names to be the same.
Feel free to throw reviews my way.
So, this is only used for talos-master.  The important bits are updating the scheduler branch name so that it has '-talos'.  The rest is just to make it semi-consistent with the buildbot-0.8.0 patch.
Attachment #465231 - Flags: review?(bhearsum)
Comment on attachment 465231 [details] [diff] [review]
Port of buildbot branch changes to default branch

Looks fine
Attachment #465231 - Flags: review?(bhearsum) → review+
Comment on attachment 465231 [details] [diff] [review]
Port of buildbot branch changes to default branch

changeset:   867:9fb29f48a6a4
Attachment #465231 - Flags: checked-in+
Comment on attachment 465633 [details] [diff] [review]
Download pageloader.xpi from build.m.o for default branch of buildbotcustom

I'm not sure why the download was ever in MobileTalosFactory at all. r+
Attachment #465633 - Flags: review?(bhearsum) → review+
Comment on attachment 465633 [details] [diff] [review]
Download pageloader.xpi from build.m.o for default branch of buildbotcustom

changeset:   868:5683977a2707
Attachment #465633 - Flags: checked-in+
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Blocks: 590369
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.