No default button selection in Profile Manager

RESOLVED FIXED

Status

Testing Graveyard
ProfileManager
RESOLVED FIXED
8 years ago
22 days ago

People

(Reporter: KitchM, Assigned: mcote)

Tracking

1.9.2 Branch
x86
Linux

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100724 Firefox/3.6.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.8) Gecko/20100724 Firefox/3.6.8  and  Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.7) Gecko/20100720 Lightning/1.0b2 Lanikai/3.1.1

When starting a Mozilla program with the Profile Manager, there is no highlighted default button.

Reproducible: Always

Steps to Reproduce:
1. Must have multiple profiles
2. Must use Profile Manager to start programs
3. Look at Profile Manager display
Actual Results:  
The manager seems to always default to the Start button rather than the Exit button, but that button is never highlighted.

Expected Results:  
The default button selection must always be highlighted so that the user knows what will happen when the Enter key is pressed.

Updated

8 years ago
Component: Widget → ProfileManager
Product: Core → Testing
QA Contact: general → profilemanager
Version: unspecified → 1.9.2 Branch
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

8 years ago
Assignee: nobody → mcote
Status: NEW → ASSIGNED
(Assignee)

Comment 1

8 years ago
Created attachment 482721 [details] [diff] [review]
Deliberately sets focus to application start button

In the current Profile Manager, there is no deliberate setting of the focus; the default focus seems to be on the first profile in the profile table.

This is a one-line patch that deliberately sets the focus on the start button.  If the button is disabled (e.g. app already running), this won't do anything, and the default focus is used, which I think is acceptable.
Attachment #482721 - Flags: review?(jgriffin)
Comment on attachment 482721 [details] [diff] [review]
Deliberately sets focus to application start button

Pushed as http://hg.mozilla.org/automation/profilemanager/rev/2e3f1e7ef578
Attachment #482721 - Flags: review?(jgriffin) → review+
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

22 days ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.