If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

javascript strict warnings in builtinURLs.js

VERIFIED FIXED

Status

SeaMonkey
General
P3
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Blake Ross, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
redeclaration of var ds_uri
(Assignee)

Comment 1

17 years ago
Created attachment 18334 [details] [diff] [review]
patch

Comment 2

17 years ago
Erm, 
87 var ds_uri = "chrome://global/locale/builtinURLs.rdf";
88 var url_ds = gRDFService.GetDataSource(ds_uri); // return nsIRDFDataSource
ds_uri, url_ds? What style are we using here? Ben: this is your code...

blake: r=timeless, but i don't like the original code, and I think it would be 
better if it were cleaned.

Comment 3

17 years ago
keywords
Keywords: approval, patch
Wow, tabs and other problems -- I don't think that's ben's doing.  More likely 
to be rjc's.  Give this file a facelift, I'll review and ben or alecf can sr=.

/be
(Assignee)

Comment 5

17 years ago
*** Bug 58563 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

17 years ago
alec's dnd fix fixed this.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
verified with build 20010126 on win2k
Status: RESOLVED → VERIFIED

Comment 8

17 years ago
sorry for the spam.... just changing the subject so that the bugs can be sorted 
correctly
Summary: Strict warning in builtinURLs.js → javascript strict warnings in builtinURLs.js
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.