Open Bug 585160 Opened 11 years ago Updated 5 years ago

Error: uncaught exception: 2147942487

Categories

(Mozilla Labs Graveyard :: Personas Plus, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

REOPENED

People

(Reporter: cbook, Assigned: jose)

Details

Steps to reproduce:

RC2 of Personas 1.6
Click on Custom Personas. Do no changes and click ok
-->

Error: uncaught exception: 2147942487 - might be related to bug 585158
Assignee: cbeard → jose
Target Milestone: -- → 1.6
There is an issue with this bug.

When the user does not specify a header or footer image file in the Custom Persona Editor, a transparent 1x1 px base64 string image is used
as a workaround for bug 532741.

The problem is that when such a persona is set (both the header and footer images set to base64 strings), the LightweightThemeManager throws the "2147942487" exception.

It used to work, but since the resolution of bug 532741 something must have changed inside the LTM.
Status: NEW → ASSIGNED
What other options do we have other than investigating/changing Firefox code? Can Personas Plus bundle a 1x1 transparent gif and load that if no images are selected?
That's a good option but the problem is that the LTM does not support chrome:// addresses either.

a) Could the image be hosted at getpersonas.com? Say something like: http://www.getpersonas.com/static/null-image.gif

b) The image could be included in the defaults folder, and have its file:// url calculated and set to the custom persona. This is slightly more complicated though.
@Ryan - What do think about those options? (comment #3)
(In reply to comment #4)
> @Ryan - What do think about those options? (comment #3)

Let's go with a, I'll add the image and file a bug. IT will probably update today or tmrw.
Oh hey, looks like it's already there! 
http://www.getpersonas.com/static/img/blank.gif
Thanks. Fixed in rev:
http://hg.mozilla.org/labs/personas/rev/ddef9c248e44

Now the blank image URL is used when no image file is set for the header or footer.

We'll generate a new RC soon.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
can reproduce this on linux when i select http://www.getpersonas.com/en-US/persona/116 from my favorite menu in the extension
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #8)
> can reproduce this on linux when i select
> http://www.getpersonas.com/en-US/persona/116 from my favorite menu in the
> extension

I'm getting the same error, but this particular personas is not returning with a name or description. It seems to be an error on the site:

{"id":"116",
"name":null,
"accentcolor":null,
"textcolor":null,
"header":"http:\/\/getpersonas-cdn.mozilla.net\/static\/1\/6\/116\/QuantumMechanicsHeader.JPG?1271542801",
"footer":"http:\/\/getpersonas-cdn.mozilla.net\/static\/1\/6\/116\/QuantumMechanicsFooter.JPG?1271542801",
"category":null,
"description":null,
"author":"Ryath",
"username":"Ryath",
"detailURL":"http:\/\/www.getpersonas.com\/persona\/116","headerURL":"http:\/\/getpersonas-cdn.mozilla.net\/static\/1\/6\/116\/QuantumMechanicsHeader.JPG?1271542801",
"footerURL":"http:\/\/getpersonas-cdn.mozilla.net\/static\/1\/6\/116\/QuantumMechanicsFooter.JPG?1271542801",
"previewURL":"http:\/\/getpersonas-cdn.mozilla.net\/static\/1\/6\/116\/preview.jpg?1271542801",
"iconURL":"http:\/\/getpersonas-cdn.mozilla.net\/static\/1\/6\/116\/preview_small.jpg?1271542801",
"updateURL":"https:\/\/www.getpersonas.com\/en-US\/update_check\/116"
}
Seems like the problem is the persona, not the add-on, those fields are required. Let's test a few other personas (preferably ones with all data available). If other personas work, we can close this bug.
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.