Spotlight search fails when metadata importer plug-in (Thunderbird.mdimporter) is absent

RESOLVED FIXED in Thunderbird 3.3a1

Status

Thunderbird
OS Integration
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Michael Tepper, Assigned: standard8)

Tracking

Thunderbird 3.3a1
x86_64
Mac OS X
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(blocking-thunderbird3.1 .7+, thunderbird3.1 .7-fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-US) AppleWebKit/533.4 (KHTML, like Gecko) Chrome/5.0.375.125 Safari/533.4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.7) Gecko/20100713 Thunderbird/3.1.1

Without the Thunderbird.mdimporter (located here: https://bugzilla.mozilla.org/attachment.cgi?id=253622), Spotlight fails to return messages based on content searches.   Furthermore, this importer does not appear to be a part of the Mac distribution (as of Thunderbird 3.1.1), and must be searched for and installed separately.  There is no indication given by the program or documentation that such actions are required for the Spotlight search functionality to work.  

Reproducible: Always

Steps to Reproduce:
1. Make sure Thunderbird.mdimporter is not installed.  (To do so search run "mdimport -L". check to make sure Thunderbird.mdimporter is not on the list)
2. Cleanly install Thunderbird, add an email account (I've only tried Gmail imap so far)
3. Make sure Spotlight indexing on, and that metadata are being stored properly in ~/Library/Caches/Metadata/Thunderbird/etc.
4. Find an email for which you have verified the metadata (i.e. .mozeml file) exists, and search for it based on sender, recipient, or message body.
Actual Results:  
Spotlight fails to return the message in the Spotlight search results.

Expected Results:  
Spotlight should have returned the message.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.1
(Reporter)

Updated

8 years ago
Summary: Spotlight search fails when metadata importer (Thunderbird.mdimporter) is absent → Spotlight search fails when metadata importer plug-in (Thunderbird.mdimporter) is absent
The importer is being build - but indeed we don't package it shall I move the bug to build config ?
blocking-thunderbird3.1: --- → ?

Comment 2

8 years ago
Yes, it needs to be in our shipping bits. I don't remember how we "install" the mdimporter, since there's no installer on the mac. The importer can go in either System/Library/Spotlight or ~/Library/Spotlight, iirc, and we could just programmatically install the importer on first run.
<http://developer.apple.com/mac/library/documentation/Carbon/Conceptual/MDImporters/Concepts/Troubleshooting.html> indicates that all you need to do is to have the mdimporter in Thunderbird.app/Contents/Library/Spotlight. It's really nice how declarative OS X is in general.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

8 years ago
Oh, ok, that must be how it works out of the box when the importer is packaged correctly - I remember Josh telling me that was deprecated, but as long as it works.
blocking-thunderbird3.1: ? → needed

Comment 5

8 years ago
I'm running 3.0.3 still and looking at my next update.

3.1.3 was released withOUT Thunderbird.app/Contents/Library/Spotlight/Thunderbird.mdimporter, which incidentally is slightly different than the one referenced in the original bug text.

3.0.7 has the same Thunderbird.mdimporter as 3.0.3.

chris
Yes we haven't had time to fix and test it yet, we'll look at it for one of the later releases.
Blocks: 516741
The try build worked. Can you attach the patch standard8 ?
blocking-thunderbird3.1: needed → .6+
Created attachment 481792 [details] [diff] [review]
The fix

Adds the required packaging for the spotlight part. Ludovic's tested a try server build with this in.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
Attachment #481792 - Flags: review?(bienvenu)

Comment 9

8 years ago
Comment on attachment 481792 [details] [diff] [review]
The fix

I'm going to rs this, since Ludo tested the try server build...
Attachment #481792 - Flags: review?(bienvenu) → review+
Checked into trunk:

http://hg.mozilla.org/comm-central/rev/8ed8483ad1d3
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
Comment on attachment 481792 [details] [diff] [review]
The fix

a=Standard8, let's get this fixed on the 1.9.2 branch for the next release.
Attachment #481792 - Flags: approval-thunderbird3.1.7+
Checked into 1.9.2: http://hg.mozilla.org/releases/comm-1.9.2/rev/be15794e4a90
status-thunderbird3.1: --- → .7-fixed
You need to log in before you can comment on or make changes to this bug.