User Interface broken in Firefox 4.0b3 (build 3)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: tigerfishdaisy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3) Gecko/20100805 Firefox/4.0b3
Build Identifier: 1.4.3 on Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3) Gecko/20100805 Firefox/4.0b3

Firefox Sync menus no longer appear under History (->Tabs from other Computers) and under Tools (->Sync).  In addition, the configuration page no longer appears under Tools->Options.  The backend (sync) still appears to work fine (bookmarks, tabs, etc... are still synced).

Reproducible: Always

Steps to Reproduce:
1.  Upgrade from Firefox 4.0b2 -> 4.0b3
Actual Results:  
Sync Interface disappeared.

Expected Results:  
Sync Interface should not have changed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584705
(Reporter)

Comment 2

8 years ago
This isn't a duplicate.  Firefox Sync works, except the UI is completely broken.  The extension is enabled with no complaints from Firefox 4.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
If by "completely broken" you mean non-existent, then that's intended. Sync 1.4.3 disables its UI on 4.0b3 or later since there was a chance that Sync would land in Firefox proper for that version. The add-on may still continue to work, perhaps because you have the add-on compatibility check disabled (through e.g. the Add-on Compatibility Reporter extension).

As of bug 584705 and 1.4.4b1 we declare compatibility with Firefox up to 4.0b4pre for both the add-on and the UI.
(Reporter)

Comment 4

8 years ago
Then why is 1.4.3 declared compatible with versions of Firefox from 3.5-4.0b4pre?
(Reporter)

Comment 5

8 years ago
Created attachment 463779 [details]
Screenshot of Sync Addon Page.
(In reply to comment #4)
> Then why is 1.4.3 declared compatible with versions of Firefox from
> 3.5-4.0b4pre?

Oh hrm, it probably shouldn't have been. Although it makes sense to have it enabled, just to ensure that it's at least working in the background, tracking your profile changes and syncing them when connected.
marking WFM, please reopen if it's not working in latest version (1.5)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.