Closed Bug 585298 Opened 13 years ago Closed 12 years ago

Syntax Highlighting feature in View Page Source window does not react instantaneously

Categories

(Toolkit :: View Source, defect)

x86_64
Windows 7
defect
Not set
minor

Tracking

()

RESOLVED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: klachoo, Unassigned)

References

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100804 Minefield/4.0b3pre
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b3pre) Gecko/20100804 Minefield/4.0b3pre

Syntax Highlighting feature in View Page Source window does not react instantaneously to the actions undertaken by the user ie. turning on/turning off syntax highlighting. To see the changes (coloured or discoloured syntax in the code) it is necessary to close the view page source window and open it again. 
The "wrap long lines" functionality works ok and instantaneously though.

The issue was noticed in builds with both en-gb and pl locale.

Reproducible: Always

Steps to Reproduce:
1.Navigate to a website of your own choice.
2.Open the View Page Source window (by mouse or keyboard shortcut).
3.In the View menu item check/uncheck the Syntax Highlighting option.
Actual Results:  
The source code of the page remains in the initial state as when the view source window was opened instead of immediately react to the user's actions and turn the syntax highlighting feature on or off. The menu item gets correctly checked/unchecked but it does not affect the code itself.

Expected Results:  
The source code should have the syntax highlighting feature enabled/disabled on the fly as user selects the appropriate option in the menu.
I can confirm.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This used to work.  Who broke it?
blocking2.0: --- → ?
In particular, this has regressed since 3.6.
This is the same underlying issue as bug 582795: loadPage got broken.
Blocks: 500328
Blocks: devtools4b8
view source has its own component, moving there.
Component: Developer Tools → View Source
Product: Firefox → Toolkit
QA Contact: developer.tools → view.source
blocking2.0: ? → final+
Flags: in-testsuite?
Version: unspecified → Trunk
Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101125 Firefox/4.0b8pre

Fixed with bug 582795
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.