Problems with HTTP 301 and 302

RESOLVED DUPLICATE of bug 584759

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 584759
7 years ago
7 years ago

People

(Reporter: Biju, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Mozilla/5.0 (Windows NT 6.0; rv:2.0b4pre) 
Gecko/20100806 Minefield/4.0b4pre

When I goto https://mail.google.com/mail/?shva=1#inbox
I get "Moved Temporarily <newline>The document has moved here." message.


I am seeing similar problems with both HTTP 301 and 302 on many sites
Do you have any extensions installed?
Sounds like a duplicate of bug 584759
(Reporter)

Comment 3

7 years ago
This is not a problem in 
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.9pre) 
Gecko/20100807 Namoroka/3.6.9pre

And disabling AdBlock Plus resolve this issue. 

So is there a spec change between Namoroka/3.6.9 and Minefield/4.0?


PS: Other extensions I need only for limited sites.
    But I cant imagine a situation where surfing the web with out AdBlock.
    I will rather dont use web or limit use of web.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 584759
> So is there a spec change between Namoroka/3.6.9 and Minefield/4.0?

There's a change in how the redirect API works, and Adblock needs to be updated to the new API.  I'm sure that will happen before 4.0 is released.
(Reporter)

Comment 5

7 years ago
Thanks Got it...
bug 546606 Comment 16
bug 546606 comment 98
https://www.mozdev.org/bugs/show_bug.cgi?id=23092
You need to log in before you can comment on or make changes to this bug.