per-contact default outgoing account

RESOLVED DUPLICATE of bug 367586

Status

Thunderbird
General
--
enhancement
RESOLVED DUPLICATE of bug 367586
8 years ago
8 years ago

People

(Reporter: ultramage, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Opera/9.80 (Windows NT 6.0; U; en) Presto/2.6.30 Version/10.60
Build Identifier: Thunderbird/5.1.2

Currently you choose one account to be the 'default', and it will be selected when composing a new e-mail. This can be changed in the email composition window, if one doesn't forget.

I have multiple accounts, and I have them subscribed to various mailing lists. It's not rare that I make a mistake (or forget) and send to the mailing list using a different account than the one that is subscribed to the list. This can cause confusion, break conversation tracking, and even be an undesired disclosure of information (that your two e-mail accounts belong to the same person). This issue is not limited to mailing lists; it's annoying with normal conversations as well.

I suggest adding a feature that would allow associating each contact with a default outgoing account. This would have the consequence of defaulting to the specified account, overriding the global default and/or UI focus rules.

Reproducible: Always

Steps to Reproduce:
1. Send an e-mail to someone using a non-default account.
2. Some time later, send an e-mail to that person again, forgetting to select the same account as before.

Actual Results:  
Recipient gets two e-mails from the same person but from two different accounts.

Expected Results:  
The user interface should help the user avoid this sort of mistake.

Might be closely related to this 3+ year old feature request: https://bugzilla.mozilla.org/show_bug.cgi?id=367586
There's a plugin that might be attempting to solve this: https://addons.mozilla.org/en-US/thunderbird/addon/1203/
Whiteboard: dupme

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 367586
You need to log in before you can comment on or make changes to this bug.