If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

“Looking at” styling broken

RESOLVED FIXED

Status

()

Firefox
Developer Tools
--
minor
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: jwalker, Assigned: msucan)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

The “looking at” line in the alternate style view should have a yellow highlight for only the last crumb in the path. The previous crumbs should be the bluey link color used elsewhere.
Similarly the red ‘>>’ should only be inbetween the crumbs, not after each.
Also all but the last crumb should be a link to highlight the element in question

Updated

7 years ago
Assignee: nobody → mihai.sucan
Whiteboard: [kd4b4]

Updated

7 years ago
Whiteboard: [kd4b4]
Also, something I forgot to mention, the links themselves are broken, as you noticed.
Blocks: 586984
(Assignee)

Comment 2

7 years ago
Created attachment 467532 [details] [diff] [review]
proposed fix

Proposed fix. This patch requires the latest patches from bug 582596.

What I did:
- the crumb only show *between* elements.
- yellow background for the final element in the path.
- blue background for the rest of the path elements. I did it lighter a bit - it was too dark and I couldn't read element names.
- Fixed overflowing of the path. It can now show any depth of path with *no* display issues.
- Now users can click the path elements to jump to element parents. Yay!
- I touched the specificity styling. It wasn't properly aligned.
- I also fixed the "N rules" float on the right, which overflowed other properties when the calculated property value was too long.
- I fixed the table alignment, which was always too large in width. Now horizontal scrollbars do not show for long rule selectors.

What I'd like is to merge this patch into the main patches ASAP. :) It looks/works more polished.
Attachment #467532 - Flags: feedback?(rcampbell)

Updated

7 years ago
Duplicate of this bug: 586979
(Assignee)

Comment 4

7 years ago
Created attachment 467765 [details]
screenshot

Screenshot for today's meeting with Limi. This image shows the styling changes I did in this patch.
(Assignee)

Comment 5

7 years ago
Created attachment 467766 [details]
screenshot 2

A screenshot showing the style panel with a really small width.
Attachment #467532 - Flags: feedback?(rcampbell) → feedback+
do we really need to make the "looking at" element that "flashy"? It stands out a bit too much on the panel. I'd be happy with just lightly-styled text. Code looks decent though.
(Assignee)

Comment 7

7 years ago
Robert: I know, you have a point. I kept the initial intent of the styling Joe did. The blue path elements had an even darker blue but I decided to lighten it up so I can read the text (I couldn't).

Should I make the blue gradient even brighter?
Status: NEW → ASSIGNED
I'm including this patch in the main style panel bug: showAll
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
cut and paste errorin last comment, sorry:
s/bug: showAll/bug: 582596/
You need to log in before you can comment on or make changes to this bug.