too aggressive e-mail address autocompletion

VERIFIED DUPLICATE of bug 131692

Status

VERIFIED DUPLICATE of bug 131692
8 years ago
6 years ago

People

(Reporter: stlman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; pl-PL; rv:1.9.1.10) Gecko/20100623 Iceweasel/3.5.10 (like Firefox/3.5.10)
Build Identifier: 

E-mail address is too aggressive. It becomes impossible to enter an address if it's been erroneously entered before like:

john@doe.com.34 <- this is an error

Now there is no other way than removing the address from the "collected addresses" to enter john@doe.com. IMHO TB should offer completion but not enforce it when cursor leaves the input field.

Reproducible: Always
Component: General → Message Compose Window
QA Contact: general → message-compose
Yes, autocomplete is WAY too aggressive, to the extent that I cannot enter a deviating address that happens to match, nor a deviating display name with existing address. Iow, it's badly broken. It's also a known problem for 10 years.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 131692
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.