bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Provide a different way of handling App Tabs in Visual Tab Interface

RESOLVED DUPLICATE of bug 578553

Status

Firefox Graveyard
Panorama
--
enhancement
RESOLVED DUPLICATE of bug 578553
8 years ago
2 years ago

People

(Reporter: Ryuji, Assigned: aza)

Tracking

Trunk
x86
Windows 7

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b4pre) Gecko/20100807 Minefield/4.0b4pre
Build Identifier: 

Currently App tabs in the Visual Tab Interface are handled like a normal Tab. They look like normal tabs but they always appear in the tab bar even when they are not in the select tab grouping. I believe it is intended behaviour for App tabs to in the tab bar all the time.

If grouping app tab into Tab Groups will not affect them, this may led to confusion among users. 

Proposed Solution 1: Show only App Tabs in selected Tab Group. Hide other App tabs that are not in Selected Tab Group. Provided that App Tabs in Visual Tab Interface look different from Normal Tabs.

Proposed Solution 2: Keep current behaviour, do not show any App Tabs in Visual Tab Interface. 

Reproducible: Always
(Reporter)

Updated

8 years ago
Blocks: 574217
Severity: normal → enhancement
Aza already has some design work and thoughts on this. Assigning it to him.
Assignee: nobody → aza
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 2

8 years ago
Aza, how are you going to solve this problem?
No longer blocks: 574217

Comment 3

8 years ago
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Component: TabCandy → TabCandy
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
Version: unspecified → Trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 578553
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.