javascript strict warnings in SearchDialog.js

VERIFIED FIXED in Future

Status

SeaMonkey
MailNews: Message Display
P5
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Henrik Gemal, Assigned: stephend@netscape.com (gone - use stephen.donner@gmail.com instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
JavaScript strict warning:
chrome://messenger/content/SearchDialog.js line 209: assignment to undeclared 
variable gSearchSession

JavaScript strict warning:
chrome://messenger/content/SearchDialog.js line 220: assignment to undeclared 
variable searchListener

JavaScript strict warning:
chrome://messenger/content/SearchDialog.js line 104: assignment to undeclared 
variable folderResource

JavaScript strict warning:
chrome://messenger/content/SearchDialog.js line 125: assignment to undeclared 
variable gCurrentFolder

Comment 1

18 years ago
Created attachment 18437 [details] [diff] [review]
proposed patch
(Reporter)

Updated

18 years ago
Summary: Lots of strict warnings in SearchDialog.js → javascript strict warnings in SearchDialog.js

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: P3 → P5
Target Milestone: --- → Future

Comment 2

17 years ago
looks fine to me, although |searchListener| seems to have since been 
removed/changed. r=blake, cc alec for sr

Comment 3

17 years ago
gCurrentFolder is a global, (hence the leading "g") can you declare it as such?

Comment 4

17 years ago
Created attachment 21190 [details] [diff] [review]
[patch] declared globally

Comment 5

17 years ago
alec, please sr. thanks.

Comment 6

17 years ago
sr=alecf

Comment 7

17 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
Verified Linux 20010106
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

17 years ago
JavaScript strict warning:
chrome://messenger/content/SearchDialog.js line 136: assignment to undeclared 
variable result
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 10

17 years ago
btw also this:
error setting DS on [xpconnect wrapped nsIRDFDataSource]: [Exception... "Compone
nt returned failure code: 0x80004002 (NS_NOINTERFACE) [nsIRDFDataSource.QueryInt
erface]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome
://messenger/content/SearchDialog.js :: setMsgDatasourceWindow :: line 325"  dat
a: no]

Comment 11

17 years ago
as I recall that "error setting datasource.." stuff is not actually a fatal
condition .. we should just remove the dump()

Comment 12

17 years ago
*** Bug 68041 has been marked as a duplicate of this bug. ***

Updated

17 years ago
QA Contact: esther → laurel

Updated

17 years ago
Assignee: blakeross → gayatrib
Status: REOPENED → NEW
QA Contact: laurel → esther

Comment 13

17 years ago
These broke after the landing, back to mailnews team.

Comment 14

17 years ago
reassigning to naving
Assignee: gayatrib → naving
QA Contact: esther → stephend

Comment 16

17 years ago
Comment on attachment 49814 [details] [diff] [review]
Patch

r=naving
Attachment #49814 - Flags: review+
Re-assigning to myself.
Assignee: naving → stephend
Fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
My bad, I missed a warning, so I filed bug 100897.
bhart, can you be the neutral verifying party on this bug?

Just enter a search term, hit the Search button, and see if you get the 

JavaScript strict warning:
chrome://messenger/content/SearchDialog.js line 136: assignment to undeclared 
variable result

Just enable JS strict warnings via the Edit | Preferences | Debug | Enable JS 
strict warnings.

If not, thanks anyways.
(Reporter)

Comment 22

17 years ago
no warnings...
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.