Last Comment Bug 585741 - Remove answers.com from list of default search engines in en-US
: Remove answers.com from list of default search engines in en-US
Status: VERIFIED FIXED
: productization
Product: Firefox
Classification: Client Software
Component: Search (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 4.0
Assigned To: Nobody; OK to take it and work on it
:
: Florian Quèze [:florian] [:flo]
Mentors:
Depends on: 603298
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 14:48 PDT by Kev Needham [:kev]
Modified: 2011-06-02 04:19 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to remove answes.com from default search plug-ins (2.37 KB, patch)
2010-08-19 05:32 PDT, Kev Needham [:kev]
gavin.sharp: review-
mbeltzner: ui‑review+
Details | Diff | Splinter Review

Description Kev Needham [:kev] 2010-08-09 14:48:26 PDT
Answers.com is currently included as a default search plug-in in the search toolbar for en-US. While billing itself as the "world's leading Q&A site", a large portion of the content it presents to users is scraped from other sources (including wikipedia, which is also a default), and it is of questionable value for users.

Alexa currently ranks Answers.com at number 63 in the US (ComScore ranks them at #22, however), and reports a high number of bounces from users of the site (one-page view and gone). From a general search perspective, there is questionable utility to users, and it makes sense to consider other search properties instead.

I'd ask that we remove answers.com for Firefox 4.0 to make room for other search services that better address user needs, and would like to know if there are major objections for doing so.
Comment 1 Mike Beltzner [:beltzner, not reading bugmail] 2010-08-18 17:42:48 PDT
Where are we with this? Happy to do what it takes, just want to make sure we remember.
Comment 2 Kev Needham [:kev] 2010-08-18 18:31:59 PDT
I'll file the patch.
Comment 3 Kev Needham [:kev] 2010-08-19 05:32:39 PDT
Created attachment 467392 [details] [diff] [review]
Patch to remove answes.com from default search plug-ins

Patch attached for removing Answers.com from the default list of search plug-ins.
Comment 4 Mike Beltzner [:beltzner, not reading bugmail] 2010-08-19 08:12:51 PDT
Comment on attachment 467392 [details] [diff] [review]
Patch to remove answes.com from default search plug-ins

Just want to get Gavin or someone to pass their eyes over the code. I'm pretty sure that's right, though.
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2010-08-19 12:04:02 PDT
Comment on attachment 467392 [details] [diff] [review]
Patch to remove answes.com from default search plug-ins

It needs to be removed from list.txt as well. Unfortunately it appears to be included in several l10n list.txts:

http://mxr.mozilla.org/l10n-central/search?string=answers&find=list.txt

We'll need to remove those first, otherwise we'll break the l10n builds.
Comment 6 Kev Needham [:kev] 2010-08-19 12:13:12 PDT
I thought those were generated. apologies. I will file the relevant patches.
Comment 7 Staś Małolepszy :stas 2010-08-20 06:43:02 PDT
I'd like to go through a discussion for every locale that ships with answers.com, to see how well the site is doing in their regions (maybe better than in the US?) and what alternatives there are potentially.

Could we just remove answers from list.txt in en-US for now, and leave the xml file in the repo, so that the l10n builds don't break? 

Once all the discussions with the l10n teams are finished, we'll put answers.xml in locales' repos where needed, and be able to remove it from en-US for good.
Comment 8 Mike Beltzner [:beltzner, not reading bugmail] 2010-08-20 07:17:50 PDT
(In reply to comment #7)
> I'd like to go through a discussion for every locale that ships with
> answers.com, to see how well the site is doing in their regions (maybe better
> than in the US?) and what alternatives there are potentially.

I'd be pretty surprised, but if you think you can gather that feedback quickly, that'd be great. How do you suspect the l10n leaders will gather the data?
Comment 9 Kev Needham [:kev] 2010-08-20 07:41:00 PDT
(In reply to comment #7)
> I'd like to go through a discussion for every locale that ships with
> answers.com, to see how well the site is doing in their regions (maybe better
> than in the US?) and what alternatives there are potentially.

My only question would be how many of those places include answers.com as a default because it's in the en-US defaults. It's only localized for French, German, Italian, Spanish, and Tagalog right now, so I'm suspecting a lot of places aren't actively including it, but if we could get quick yays or nays that'd be great.
Comment 10 Kev Needham [:kev] 2010-10-11 03:56:24 PDT
This change has been rolled into bug 603298 and, per l10n request, the default plugins have been left in place with just list.txt edited to remove it from the en-US defaults.
Comment 11 Ed Morley [:emorley] 2011-05-30 07:25:30 PDT
(In reply to comment #10)
> This change has been rolled into bug 603298 

Bug 603298 is fixed, can this be closed now?
Comment 12 Axel Hecht [:Pike] 2011-05-30 07:27:08 PDT
Yes.
Comment 13 Simona B [:simonab ] 2011-06-02 04:19:28 PDT
Mozilla/5.0 (Windows NT 5.1; rv:7.0a1) Gecko/20110531 Firefox/7.0a1

Verified issue on WinXP, Win7, MacOS X 10.6, Ubuntu 10.10. "answer.com" is removed from the default search engines.

Note You need to log in before you can comment on or make changes to this bug.