Parser bug with anchors and PRE tags

VERIFIED DUPLICATE of bug 54834

Status

()

Core
HTML: Parser
P3
major
VERIFIED DUPLICATE of bug 54834
18 years ago
18 years ago

People

(Reporter: mkaply, Assigned: rickg)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
The following html:

<a name=anchorlink>
<pre>
Pre tag starts here
This text is pre
<a href="not really a link">This link turns off pre because of the anchor</a>
And the rest of the text is not pre
</pre>

Is broken in Mozilla.

It does work on IE5 as well as 4.61.

It appears that the anchor within the PRE tag is throwing off the parser. Note 
that named anchor must be above the <PRE> for this to break.
(Reporter)

Comment 1

18 years ago
Sorry. wrong component
Component: Layout → Parser
(Reporter)

Comment 2

18 years ago
Argh
Assignee: clayton → harishd
QA Contact: petersen → janc
(Reporter)

Comment 3

18 years ago
Everyone on IRC told me to CC rickg.

And since I have already spammed people so much with this bug, what's one more?
(Assignee)

Comment 4

18 years ago
I think I already have a fix for this, which I'm hoping to land shortly on the 
trunk (with about a dozen other little bug fixes). I'll take this bug until I 
can determine whether it's a dup.
Assignee: harishd → rickg
(Assignee)

Comment 5

18 years ago
Dup of 54834.

*** This bug has been marked as a duplicate of 54834 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.