Temporary hangs when zooming on Google Maps satellite view

RESOLVED FIXED

Status

()

RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: evans.antony, Unassigned)

Tracking

unspecified
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 betaN+)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3) Gecko/20100805 Firefox/4.0b3 Firefox/3.6.4
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; rv:2.0b3) Gecko/20100805 Firefox/4.0b3

Whilst using satellite view in Google Maps to zoom in/out, Firefox will hang for about 30 seconds to 1 minute. CPU usage spikes during this time. After about 1 minute the map will display and Firefox becomes responsive again.

Reproducible: Always

Steps to Reproduce:
1. Open Google maps
2. Switch to satellite view
3. Zoom in or out
Actual Results:  
Firefox hangs for up to 1 minute, map eventually displays and Firefox becomes responsive

Expected Results:  
Firefox should not hang, map should display within a few seconds

Also tested this on nightly build, same problem occurred.
Mozilla/5.0 (Windows NT 6.1; rv:2.0b4pre) Gecko/20100809 Minefield/4.0b4pre - Build ID: 20100809040505

This is a regression since Firefox 4.0 beta 2

Comment 1

8 years ago
I confirmed:
Regression Window:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5f857be14db9&tochange=b8b62b351c09
I guess landing of Bug 572520 causes the problem

Updated

8 years ago
Blocks: 572520

Comment 2

8 years ago
I confirm this on Linux builds.

All the same symptoms as Tony-E reported above.

In addition, if one tries the 'drag' the window with the left mouse button held down in order to change the view field, the re-rendering takes longer to complete than expected from performance in Firefox 3.6.* builds and also during this time there are very high CPU spikes.  In Linux process monitor (top) 'firefox-bin' has high CPU usage but it is 'X' that appears to be hogging the CPU with values of around 60-70% (this is in addition to the 30-40 % of 'firefox-bin').

I guess this effect will be more noticed in lower end or older hardware configurations.
Status: UNCONFIRMED → NEW
blocking2.0: --- → ?
Component: General → ImageLib
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → imagelib
blocking2.0: ? → betaN+
I'm hoping that this will be fixed by the patch over at bug 583028.

Joe made some tryserver builds with that patch, though unfortunately it seems they didn't get built on windows for some reason. Can those of you experiencing this problem on linux and mac give this build a spin?

http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/jdrew@mozilla.com-c133ae00e4a3/

Comment 4

8 years ago
(In reply to comment #3)
> I'm hoping that this will be fixed by the patch over at bug 583028.
> 
> Joe made some tryserver builds with that patch, though unfortunately it seems
> they didn't get built on windows for some reason. Can those of you experiencing
> this problem on linux and mac give this build a spin?
> 
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tryserver-builds/jdrew@mozilla.com-c133ae00e4a3/

I've just tried out that tryserver Linux build.  That build works much better on the Google maps than the present 'trunk' builds.  It is perhaps not quite as quick to finish rendering after dragging this image as with the 3.6.* builds, but much better and now quite usable.
(Reporter)

Comment 5

8 years ago
Since the patch for bug 583028 landed on mozilla-central, Google Maps are working again. Rendering speed is similar to 3.6.8 builds. Tested on Windows.
(In reply to comment #5)
> Since the patch for bug 583028 landed on mozilla-central, Google Maps are
> working again. Rendering speed is similar to 3.6.8 builds. Tested on Windows.

Awesome! Resolving fixed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.