F11 not working for entering or exiting from Full Screen view

RESOLVED WORKSFORME

Status

()

Firefox
Keyboard Navigation
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Steve Johnson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2
Build Identifier: Mozilla/5.0 (Windows; Windows NT 6.1; WOW64; rv:2.0b2) Gecko/20100720 Firefox/4.0b2

I hve discovered my keyboard F11 key does not change the view to full screen, it can only be done via the menu, and then whilst in full screen as F11 doesn't work it's impossible to get back to normal view.  I used Alt+Tab to get to and close the window.

Reproducible: Always

Steps to Reproduce:
1.Press F11
2.Press F11 again
3.Give up and go to View/Full Screen
Actual Results:  
as above

Expected Results:  
F11 should work to change view to and from Full Screen

Comment 1

8 years ago
WFM in latest trunk. Does F11 work with your keyboard in other applications?
(Reporter)

Comment 2

8 years ago
Very strange, I only tried full screen in Firefox 4 for the first time yesterday, and upon finding this bug, tried restarting Firefox and rebooting the PC -  to no effect, still had the problem.  Today it works fine, as it should using F11.  And yes, F11 was working in other apps with no problems.

Sorry about that, but cannot understand how it fixed itself overnight?

Steve J

Comment 3

8 years ago
Possible a plugin such as Flash had focus, which causes the keyboard events to be missed. Which is bug 78414 but there is no clear indication that was the issue. Marking works for me then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.